summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--src/xpi.mk14
3 files changed, 19 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b6c8db6..d2e4759 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,8 +17,12 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
- override files on xpi extraction (otherwise running build target would
require user interaction)
- update src/xpi.mk
+ - only list packages in ${xpi:Depends} if they are available in the archive
+ and add lsb-release as dependency
+ - update src/xpi.mk
+ - update debian/control
- -- Benjamin Drung <bdrung@ubuntu.com> Mon, 07 Sep 2009 22:59:11 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Sun, 13 Sep 2009 18:29:26 +0200
mozilla-devscripts (0.15) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 6dbdb17..715008f 100644
--- a/debian/control
+++ b/debian/control
@@ -16,6 +16,7 @@ Architecture: all
Depends: dpkg-dev,
fakeroot,
libxml-xpath-perl,
+ lsb-release,
python,
quilt,
unzip,
diff --git a/src/xpi.mk b/src/xpi.mk
index d9166f7..1a52866 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -129,6 +129,10 @@ packages_{a79fe89b-6662-4ff4-8e88-09950ad4dfde} := conkeror
packages_prism@developer.mozilla.org := prism
packages_toolkit@mozilla.org := xulrunner-1.9 xulrunner-1.9.1 xulrunner-1.9.2 xulrunner-1.9.3
+# distribution package list
+Debian_packages := iceweasel icedove iceape conkeror xulrunner-1.9 xulrunner-1.9.1
+Ubuntu_packages := abrowser-3.5 firefox-3.0 firefox-3.5 thunderbird seamonkey conkeror prism xulrunner-1.9 xulrunner-1.9.1
+
# data for XPI_DEPENDS/CHECK_VERSION magic - targetApplication min-/maxVersions
# call parameters_
# 1- target app id
@@ -150,9 +154,17 @@ MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
MOZ_XPI_DOCUMENTED_LICENSE_FILES ?= $(strip $(shell find * -iname copying -o -iname licen[cs]e -o -iname licen[cs]e.txt))
-XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
+ALL_XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))
+# list only packages, which are available in the distribution
+DISTRIBUTION := $(shell lsb_release -si)
+ifneq ($($(DISTRIBUTION)_packages),)
+XPI_DEPENDS = $(filter $($(DISTRIBUTION)_packages),$(ALL_XPI_DEPENDS))
+else
+XPI_DEPENDS = ALL_XPI_DEPENDS
+endif
+
TEMPDIR := temp-xpi-unpacked
ifneq (,$(MOZ_XPI_FILE))