summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--src/Makefile3
-rwxr-xr-xsrc/mozclient.pl5
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm2
-rw-r--r--src/mozclient/remove.binonly.sh (renamed from src/remove.binonly.sh)0
5 files changed, 11 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a00ae8..31781ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -40,6 +40,12 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- add src/src/prism.mk.in
- update src/Makefile
- update README
+ + use an absolute path for remove.binonly.sh as with --conf-dir it could
+ be called from anywhere. Move remove.binonly.sh into mozclient
+ - move src/remove.binonly.sh => src/mozclient/remove.binonly.sh
+ - update src/Makefile
+ - update src/mozclient.pl
+ - update src/mozclient/lib/MozClient/VCS.pm
* [ compare ]
+ Add build-tree/dist to the list of directories for compare1
diff --git a/src/Makefile b/src/Makefile
index d2d6dd3..de2bf61 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -42,7 +42,6 @@ subst_files = \
$(NULL)
extra_files = \
- remove.binonly.sh \
xpi.mk \
lp-locale-export.mk \
mozclient.pl \
@@ -70,10 +69,10 @@ build: $(subst_files)
install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(dir)/*))
install -m 755 -d $(DESTDIR)$(DATADIR) $(foreach dir,$(extra_dirs),$(DESTDIR)$(DATADIR)/$(dir))
install -m 644 $(subst_files) $(extra_files) $(DESTDIR)$(DATADIR)
- chmod 755 $(DESTDIR)$(DATADIR)/*.sh
for dir in $(extra_dirs) ; do \
install -m 644 `echo $$dir/*` $(DESTDIR)$(DATADIR)/$$dir ; \
done
+ find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
clean:
rm -f $(subst_files)
diff --git a/src/mozclient.pl b/src/mozclient.pl
index 591ba86..30a9722 100755
--- a/src/mozclient.pl
+++ b/src/mozclient.pl
@@ -22,6 +22,7 @@
use strict;
use Getopt::Long qw(:config no_auto_abbrev no_ignore_case
require_order bundling);
+use Cwd 'abs_path';
BEGIN {
my $conf_dir = "/usr/share/mozilla-devscripts/mozclient";
@@ -42,7 +43,7 @@ BEGIN {
}
$INC[0] =~ m,(.*)/lib$,;
-my $mozclient_dir = $1;
+my $mozclient_dir = abs_path($1);
my $pkg_conf_dir = "$mozclient_dir";
my $patches_dir = "$pkg_conf_dir/patches";
my $work_dir = "mozclient-tmp";
@@ -57,7 +58,7 @@ my @conf_list = qw(MOZCLIENT_FILE);
my $defaults = {
'MOZCLIENT_SEPARATOR' => '~',
- 'MOZCLIENT_EXCLUDE_SCRIPT' => 'remove.binonly.sh',
+ 'MOZCLIENT_EXCLUDE_SCRIPT' => "$pkg_conf_dir/remove.binonly.sh",
'MOZILLA_CLIENT' => 'mozilla/client.mk',
'MOZCLIENT_PATCHES' => "$patches_dir",
};
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index 9cddbf8..8471222 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -269,7 +269,7 @@ sub nobin_cleanup {
$self->LOG("MozClient::nobin_cleanup()");
$self->chdir($self->work_dir . "/mozilla");
- my $cmd = sprintf "sh ../../%s > REMOVED+${nobinonly}.txt 2>&1",
+ my $cmd = sprintf "sh %s > REMOVED+${nobinonly}.txt 2>&1",
$self->{'MOZCLIENT_EXCLUDE_SCRIPT'};
$self->run_shell($cmd);
$self->unlink("REMOVED+${nobinonly}.txt")
diff --git a/src/remove.binonly.sh b/src/mozclient/remove.binonly.sh
index df04617..df04617 100644
--- a/src/remove.binonly.sh
+++ b/src/mozclient/remove.binonly.sh