summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_xul-ext4
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0136ed7..b369eb9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,8 @@
mozilla-devscripts (0.46) UNRELEASED; urgency=medium
- * Fix generating Breaks: entries in light of icedove's new 1: epoch in Debian.
+ * Fix generating versions in light of Icedove's new 1: epoch in Debian.
Thanks to Guido Günther for the patch (Closes: #825508).
+ * Extend Guido's fix to handle Ubuntu's existing 1: epoch for Thunderbird.
-- Sean Whitton <spwhitton@spwhitton.name> Thu, 07 Jul 2016 10:04:52 +0900
diff --git a/dh_xul-ext b/dh_xul-ext
index 9f1450e..bea97cc 100755
--- a/dh_xul-ext
+++ b/dh_xul-ext
@@ -57,6 +57,10 @@ class XulApp(object):
and self.xul_id == THUNDERBIRD_ID
and compare_versions(version, "45") >= 0):
return 1
+ elif (get_vendor() == 'Ubuntu'
+ and self.xul_id == THUNDERBIRD_ID
+ and compare_versions(version, "24") >= 0):
+ return 1
else:
return 0