summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--src/mozclient/lib/MozClient/Mercurial.pm10
2 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e09bc65..bc73dbc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mozilla-devscripts (0.12) UNRELEASED; urgency=low
+
+ * [ mozclient ]
+ - fix hg incorrectly requesting branches
+ - update src/mozclient/lib/MozClient/Mercurial.pm
+
+ -- Fabien Tassin <fta@ubuntu.com> Wed, 26 Nov 2008 15:43:32 +0100
+
mozilla-devscripts (0.11) jaunty; urgency=low
* Bump Standards-Version to 3.8.0
diff --git a/src/mozclient/lib/MozClient/Mercurial.pm b/src/mozclient/lib/MozClient/Mercurial.pm
index 45fcbbc..40f2879 100644
--- a/src/mozclient/lib/MozClient/Mercurial.pm
+++ b/src/mozclient/lib/MozClient/Mercurial.pm
@@ -78,10 +78,14 @@ sub checkout {
$self->{'MOZCLIENT_PROJECT'}, $module);
}
}
- my $cmd = sprintf "hg clone %s %s %s %s", $self->{'mozclient_date'},
- $self->{'co_tag'}, join(" ", @$modules), $self->{'MOZCLIENT_MOZDIRNAME'};
+ my $cmd = sprintf "hg clone %s %s", join(" ", @$modules),
+ $self->{'MOZCLIENT_MOZDIRNAME'};
$self->run_system($cmd);
- $self->chdir("..");
+ $self->chdir($self->{'MOZCLIENT_MOZDIRNAME'});
+ my $rev = $self->{'mozclient_date'} ? $self->{'mozclient_date'} : $self->{'co_tag'};
+ $cmd = sprintf "hg update %s", $rev;
+ $self->run_system($cmd);
+ $self->chdir("../..");
}
sub tar_exclude {