summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/lp-locale-export.mk15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/lp-locale-export.mk b/src/lp-locale-export.mk
index f09aaf9..20a6806 100644
--- a/src/lp-locale-export.mk
+++ b/src/lp-locale-export.mk
@@ -52,12 +52,15 @@ MOZCALL_filter_manifest_locales_by_lang_to_norm = \
MOZCALL_manifest_locale_files_to_outdir = \
$(shell \
if test `grep -c ^locale $(1)` -gt 0; then \
- tar -c -C `dirname $(1)`/ -f - \
- `cat $(1) | \
- grep "^locale " | \
- grep " $(2) " | \
- sed -e 's/^.* $(2) jar:\(.*\)!.*$$/\1/' \
- ` | \
+ localefiles=`cat $(1) | \
+ grep "^locale[[:space:]]" | \
+ grep "[[:space:]]$(2)[[:space:]]" | \
+ sed -e 's/^.*[[:space:]]$(2)[[:space:]]jar:\(.*\)!.*$$/\1/' | \
+ sed -e 's/^.*[[:space:]][[:space:]]*$(2)[[:space:]][[:space:]]*\(.*\)$$/\1/' \
+ `; \
+ echo "tar -c -C `dirname $(1)`/ -f - $$localefiles \| \
+ tar -C $(3) -x -f - " > /tmp/cmd; \
+ tar -c -C `dirname $(1)`/ -f - $$localefiles | \
tar -C $(3) -x -f -; \
fi \
)