summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--src/compare.mk.in4
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 57b4aa4..657ce37 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,8 +13,12 @@ mozilla-devscripts (0.11) UNRELEASED; urgency=low
- move thunderbird-3.0 from cvs to hg comm-central
- update src/mozclient/thunderbird-3.0.conf
- add src/mozclient/thunderbird-3.0-remove.binonly.sh
+ * [ compare ]
+ search for $(DEB_BUILDDIR)/mozilla/dist/bin, needed
+ by mozilla packages using MOZ_OBJDIR
+ - update src/compare.mk.in
- -- Fabien Tassin <fta@ubuntu.com> Fri, 19 Sep 2008 18:31:05 +0200
+ -- Fabien Tassin <fta@ubuntu.com> Sat, 20 Sep 2008 01:21:36 +0200
mozilla-devscripts (0.10) intrepid; urgency=low
diff --git a/src/compare.mk.in b/src/compare.mk.in
index 8cba960..12abcf0 100644
--- a/src/compare.mk.in
+++ b/src/compare.mk.in
@@ -54,6 +54,10 @@ compare:
find build-tree/dist/bin \! -type d | cut -d/ -f4- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
elif [ -d dist ] ; then \
find dist/bin \! -type d | cut -d/ -f3- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ elif [ -d $(DEB_BUILDDIR)/mozilla/dist ] ; then \
+ find $(DEB_BUILDDIR)/mozilla/dist/bin \! -type d | cut -d/ -f5- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ else \
+ echo "Error: Can't find any suitable dist/bin directory" ; \
fi ; \
find debian/tmp -type f | cut -d/ -f3- | $(COMPARE_FILTER_PRE_OUT) | sort > $(LIST_INSTALLED) ; \
echo "## Compare the content of dist/bin and debian/tmp..." ; \