summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README31
-rw-r--r--debian/changelog1
2 files changed, 32 insertions, 0 deletions
diff --git a/README b/README
index f570c7a..b34cda4 100644
--- a/README
+++ b/README
@@ -224,3 +224,34 @@ through launchpad.
XXX: document here!
+
+=== med-xpi-unpack ===
+
+This script unpacks XPI file to the provided output directory. After unpacking
+the XPI file, it will look for JAR files in the output directory. All JAR files
+will be unpacked to $JAR_FILE with "!" appended. For example, "test.jar" is
+unpacked to "test.jar!" directory. After unpacking, the script removes all JAR
+files.
+To run it, pass the name of the XPI file, and the name of the output directory:
+
+$ med-xpi-unpack ubufox.xpi output
+
+In case some of the parameters are missing, input XPI file doesn't exist, or
+output directory already exists, it will report an error and exit.
+
+
+=== med-xpi-pack ===
+
+This script prepares a XPI file from the provided input directory. First, it
+will look for all unpacked JAR files in the input directory. Directories with
+the unpacked JAR files have the format explained in med-xpi-unpack section. The
+script will pack the contents of the directory to the JAR file, named like the
+JAR directory, with stripped "!" sign. For example, contents of "test.jar!" are
+packed to "test.jar" file. After that, it will remove all JAR directories.
+Finally, it will pack the contents of the input directory to the XPI file.
+To run it, pass the name of the input directory, and the name of the XPI file:
+
+$ med-xpi-pack ubufox ubufox.xpi
+
+In case some of the parameters are missing, input directory doesn't exist, or
+output XPI file already exists, it will report an error and exit.
diff --git a/debian/changelog b/debian/changelog
index 55d68d7..4f0bb08 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ mozilla-devscripts (0.10) UNRELEASED; urgency=low
* Open tree for 0.10 development.
* Add src/med-xpi-{pack,unpack} scripts to manage packing and unpacking of
XPI files.
+ * Document src/med-xpi-{pack,unpack} scripts in README
-- Sasa Bodiroza <jazzva@gmail.com> Tue, 08 Jul 2008 16:23:05 +0200