summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..93207d8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,22 @@
+PREFIX ?= /usr
+DOCDIR ?= $(PREFIX)/share/doc/mozilla-devscripts
+MANDIR ?= $(PREFIX)/share/man
+
+MANPAGES := $(wildcard man/*.1)
+
+build:
+ $(MAKE) -C src $@
+
+test:
+ tests/test-moz-version
+
+install:
+ install -d $(DESTDIR)$(DOCDIR) $(DESTDIR)$(MANDIR)/man1
+ install $(MANPAGES) $(DESTDIR)$(MANDIR)/man1/
+ install -m 644 README $(DESTDIR)$(DOCDIR)/README
+ $(MAKE) -C src $@
+
+clean:
+ $(MAKE) -C src $@
+
+.PHONY: build clean install test