summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile b/src/Makefile
index ffb3e49..4ced5c7 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -23,6 +23,8 @@ MANDIR ?= $(PREFIX)/share/man
DATADIR = $(PREFIX)/share/mozilla-devscripts
+VENDOR := $(shell if dpkg-vendor --is Ubuntu || dpkg-vendor --derives-from Ubuntu; then echo "Ubuntu"; else echo "Debian"; fi)
+
subst_files = \
firefox-3.0.mk \
firefox-3.0-full.mk \
@@ -92,7 +94,7 @@ install: $(subst_files) $(extra_files) $(foreach dir,$(extra_dirs),$(wildcard $(
done
find $(DESTDIR)$(DATADIR) -type f \( -name \*.pl -o -name \*.sh \) -exec chmod -v 755 {} \;
chmod 755 $(DESTDIR)$(DATADIR)/minefield-packager.mk
- install -m 644 xul-app-data.csv.$(shell lsb_release -si) $(DESTDIR)$(DATADIR)/xul-app-data.csv
+ install -m 644 xul-app-data.csv.$(VENDOR) $(DESTDIR)$(DATADIR)/xul-app-data.csv
mkdir -p $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence
install -m 644 xul-ext.pm $(DESTDIR)/usr/share/perl5/Debian/Debhelper/Sequence/xul_ext.pm