summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 0000000..ef645e9
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,54 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Description: Build system for mozclient
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+PREFIX ?= /usr
+
+DATADIR = $(PREFIX)/share/mozclient
+
+mk_files = \
+ firefox-3.0.mk \
+ lightning-sunbird.mk \
+ nspr.mk \
+ nss.mk \
+ seamonkey-2.0.mk \
+ thunderbird-3.0.mk \
+ xulrunner-1.9.mk \
+ mozclient.mk \
+ $(NULL)
+
+extra_mk_files = \
+ remove.binonly.sh \
+ $(NULL)
+
+%.mk: %.mk.in
+ cat $< | sed \
+ -e "s|^\(include\) \(.*\)|\1 $(DATADIR)/\2|" \
+ -e "s|^\(MOZCLIENT_EXCLUDE_SCRIPT.*=[ ][ ]*\)\(.*\)|\1$(DATADIR)/\2|" \
+ > $@
+ chmod 644 $@
+
+build: $(mk_files)
+
+install: $(mk_files) $(extra_mk_files)
+ install -m 755 -d $(DESTDIR)$(DATADIR)
+ install -m 644 $^ $(DESTDIR)$(DATADIR)
+
+clean:
+ rm -f $(mk_files)