summaryrefslogtreecommitdiff
path: root/src/firefox-3.1.mk.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/firefox-3.1.mk.in')
-rw-r--r--src/firefox-3.1.mk.in69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/firefox-3.1.mk.in b/src/firefox-3.1.mk.in
new file mode 100644
index 0000000..000e39d
--- /dev/null
+++ b/src/firefox-3.1.mk.in
@@ -0,0 +1,69 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project firefox 3.1
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_TARGET := firefox-3.1-orig
+MOZCLIENT_APPNAME := firefox-3.1
+MOZCLIENT_PROJECT := mozilla-central
+MOZCLIENT_FILE := mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION := sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' $(MOZCLIENT_FILE)
+MOZCLIENT_VCS := hg
+MOZCLIENT_POSTCOCMD := cd mozilla && python client.py checkout
+MOZCLIENT_URL := http://hg.mozilla.org/index.cgi/$(MOZCLIENT_PROJECT)/log
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | \
+ grep cite | head -1 | sed -e 's,.*</cite>,,' | \
+ perl -e '$$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, \
+ "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $$a = <>; \
+ $$a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { \
+ printf "%d~%04d%02d%02d\n", $$4, $$3, $$$$m{$$2}, $$1 }; '
+MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in
+
+COMPARE_FILTER_PRE_IN := sed \
+ -e 's,foo,bar,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT := sed \
+ -e 's,^usr/lib/firefox-3.1[^/]*/,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN := sed \
+ -e 's,^usr/lib/firefox-3.1[^/]*/searchplugins,usr/lib/firefox-addons/searchplugins,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/extensions/inspector@mozilla.org/.*,,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/defaults/profile,etc/firefox-3.1/profile,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/\(old-homepage-default.properties\|README.txt\|removed-files\),,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/.autoreg,,' \
+ -e 's,^etc/firefox-3.1[^/]*/.autoreg,,' \
+ $(NULL)
+
+COMPARE_FILTER_OUT := sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/lib/debug/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ -e 's,^usr/share/menu/.*,,' \
+ -e 's,^usr/share/applications/.*,,' \
+ -e 's,^usr/share/bug/firefox-3.1/presubj,,' \
+ -e 's,^etc/firefox-3.1/\(firefoxrc\|pref/firefox.js\),,' \
+ -e 's,^usr/lib/firefox-addons/searchplugins/\(debsearch\|wikipedia\).\(gif\|src\),,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/\(firefox-3.1-restart-required.update-notifier\|firefox.cfg\|firefox.sh\|ffox-4-beta-profile-migration-dialog\),,' \
+ $(NULL)
+
+include compare.mk.in