summaryrefslogtreecommitdiff
path: root/src/mozclient/patches/xulbrowser_target.patch
diff options
context:
space:
mode:
Diffstat (limited to 'src/mozclient/patches/xulbrowser_target.patch')
-rw-r--r--src/mozclient/patches/xulbrowser_target.patch116
1 files changed, 116 insertions, 0 deletions
diff --git a/src/mozclient/patches/xulbrowser_target.patch b/src/mozclient/patches/xulbrowser_target.patch
new file mode 100644
index 0000000..5355c88
--- /dev/null
+++ b/src/mozclient/patches/xulbrowser_target.patch
@@ -0,0 +1,116 @@
+---
+ mozilla/client.mk | 38 +++++++++++++++++++++++++++++++++++---
+ 1 file changed, 35 insertions(+), 3 deletions(-)
+
+Index: mozclient-tmp/mozilla/client.mk
+===================================================================
+--- mozclient-tmp.orig/mozilla/client.mk
++++ mozclient-tmp/mozilla/client.mk
+@@ -55,16 +55,17 @@
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
++# xulbrowser (aka Firefox using libxul from xulrunner)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+ # tamarin
+ #
+@@ -104,16 +105,17 @@
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
+ suite \
+ toolkit \
+ browser \
++ xulbrowser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+ camino \
+ necko \
+ tamarin \
+@@ -261,38 +263,68 @@
+ extensions/reporter \
+ extensions/spellcheck \
+ $(NULL)
+
+ BOOTSTRAP_suite := \
+ $(BOOTSTRAP_toolkit) \
+ $(NULL)
+
++MODULES_NS_xulbrowser := \
++ $(MODULES_NS_necko) \
++ $(NULL)
++
+ MODULES_NS_browser := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
++MODULES_xulbrowser := \
++ mozilla/README \
++ mozilla/config \
++ mozilla/build \
++ mozilla/intl \
++ mozilla/modules/libpref \
++ mozilla/tools/test-harness \
++ mozilla/extensions \
++ mozilla/toolkit \
++ mozilla/xpinstall \
++ mozilla/browser \
++ mozilla/probes \
++ mozilla/memory \
++ mozilla/other-licenses/branding/firefox \
++ mozilla/other-licenses/7zstub/firefox \
++ $(NULL)
++
+ MODULES_browser := \
+ $(MODULES_toolkit) \
+ mozilla/browser \
+ mozilla/other-licenses/branding/firefox \
+ mozilla/other-licenses/7zstub/firefox \
+ $(NULL)
+
+-LOCALES_browser := \
+- $(LOCALES_toolkit) \
++LOCALES_xulbrowser := \
+ browser \
+ extensions/reporter \
+ extensions/spellcheck \
+ other-licenses/branding/firefox \
+ $(NULL)
+
++LOCALES_browser := \
++ $(LOCALES_toolkit) \
++ $(LOCALES_xulbrowser) \
++ $(NULL)
++
++BOOTSTRAP_xulbrowser := \
++ mozilla/browser/config/version.txt \
++ mozilla/browser/config/mozconfig \
++ $(NULL)
++
+ BOOTSTRAP_browser := \
+ $(BOOTSTRAP_toolkit) \
+- mozilla/browser/config/mozconfig \
++ $(BOOTSTRAP_xulbrowser) \
+ $(NULL)
+
+ MODULES_NS_minimo := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
+ MODULES_minimo := \
+ $(MODULES_toolkit) \