summaryrefslogtreecommitdiff
path: root/src/nspr.mk.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/nspr.mk.in')
-rw-r--r--src/nspr.mk.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/nspr.mk.in b/src/nspr.mk.in
new file mode 100644
index 0000000..ece12da
--- /dev/null
+++ b/src/nspr.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Description: Project NSPR
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+MOZCLIENT_TARGET := nspr-orig
+MOZCLIENT_APPNAME := nspr
+MOZCLIENT_PROJECT := nspr
+MOZCLIENT_FILE := mozilla/nsprpub/configure.in
+MOZCLIENT_GETVERSION := grep -E '^MOD_(MAJOR|MINOR|PATCH)_VERSION' $(MOZCLIENT_FILE) | cut -d= -f2 | tr '\n' '.' | sed -e 's,\.$$,,'
+MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fnsprpub&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1177522884&maxdate=1588258884&cvsroot=%2Fcvsroot'
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk