summaryrefslogtreecommitdiff
path: root/src/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py31
1 files changed, 0 insertions, 31 deletions
diff --git a/src/setup.py b/src/setup.py
deleted file mode 100644
index 9dbd571..0000000
--- a/src/setup.py
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/usr/bin/python
-
-import os
-import re
-
-from distutils.core import setup
-
-# look/set what version we have
-changelog = "../debian/changelog"
-if os.path.exists(changelog):
- head = open(changelog).readline()
- match = re.compile(".*\((.*)\).*").match(head)
- if match:
- version = match.group(1)
-
-scripts = [
- 'dh_xul-ext',
- 'install-xpi',
- 'xpi-pack',
- 'xpi-repack',
- 'xpi-unpack',
- 'moz-version',
-]
-
-if __name__ == '__main__':
- setup(name='mozilla-devscripts',
- version=version,
- url='https://launchpad.net/mozilla-devscripts',
- scripts=scripts,
- py_modules=['moz_version'],
- )