summaryrefslogtreecommitdiff
path: root/src/xpi-data-all.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi-data-all.mk')
-rw-r--r--src/xpi-data-all.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/xpi-data-all.mk b/src/xpi-data-all.mk
new file mode 100644
index 0000000..9ee4cc2
--- /dev/null
+++ b/src/xpi-data-all.mk
@@ -0,0 +1,51 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2009 Canonical Ltd.
+# Author(s): Benjamin Drung <bdrung@ubuntu.com>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+_xpi_makefile_path ?= /usr/share/mozilla-devscripts
+
+ifndef _xpi_data_all
+_xpi_data_all = 1
+
+abrowser-3.0_sol := 3.0a8
+abrowser-3.0_eol := 3.0.*
+abrowser-3.6_sol := 3.6a1pre
+abrowser-3.6_eol := 3.6.*
+abrowser-3.7_sol := 3.7a1pre
+abrowser-3.7_eol := 3.7.*
+firefox-3.6_sol := 3.6a1pre
+firefox-3.6_eol := 3.6.*
+firefox-3.7_sol := 3.7a1pre
+firefox-3.7_eol := 3.7.*
+
+thunderbird-3.0_sol := 3.0a1pre
+thunderbird-3.0_eol := 3.0.*
+
+xulrunner-1.9.2_sol := 1.9.2a1pre
+xulrunner-1.9.2_eol := 1.9.2.*
+xulrunner-1.9.3_sol := 1.9.3a1pre
+xulrunner-1.9.3_eol := 1.9.3.*
+
+packages_{ec8030f7-c20a-464f-9b0e-13a3a9e97384} += firefox-3.7 abrowser-3.7 firefox-3.6 abrowser-3.6 abrowser-3.0
+packages_{3550f703-e582-4d05-9a08-453d09bdfdc6} += thunderbird-3.0
+packages_toolkit@mozilla.org += xulrunner-1.9.3 xulrunner-1.9.2
+
+include $(_xpi_makefile_path)/xpi-data-Debian.mk
+include $(_xpi_makefile_path)/xpi-data-Ubuntu.mk
+
+endif