summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index cd17a5c..e1324aa 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -37,9 +37,13 @@
# if defined the given command will be run _before_ the extension
# gets packaged up the standard .xpi way. Thus, the build command
# should produce an .xpi in top level directory. Note: If this
-# command is specified, all .xpi files in the top level directory
-# will be removed during |clean|. If the .xpi file will not be
-# build from source, you have to set this variable to nothing.
+# command is specified, MOZ_XPI_CLEAN_COMMAND (see below) will be
+# run during |clean|. If the .xpi file will not be build from
+# source, you have to set this variable to nothing.
+#
+# MOZ_XPI_CLEAN_COMMAND (OPTIONAL):
+# only has an effect if MOZ_XPI_BUILD_COMMAND (see above) is set.
+# It defaults to `rm -f *.xpi`.
#
# MOZ_XPI_MOZILLA_EXTRA_DIRS (OPTIONAL):
# defines extra directories to link the extension in. Usually
@@ -86,6 +90,7 @@
MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
MOZ_XPI_BUILD_COMMAND ?= xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi
+MOZ_XPI_CLEAN_COMMAND ?= rm -f *.xpi
ifneq (,$(MOZ_XPI_FILE))
xpi_file = $(wildcard $(MOZ_XPI_FILE))
@@ -131,7 +136,7 @@ ifneq (,$(MOZ_XPI_BUILD_COMMAND))
clean::
dh_testdir
dh_clean
- rm -f *.xpi
+ $(MOZ_XPI_CLEAN_COMMAND)
endif
.PHONY: clean xpi-install