summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index a929c45..d7e8467 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -65,6 +65,11 @@
# permission of the files will be set to 644 and the permissions
# of scripts (files containing a shebang) will be set to 755.
#
+# MOZ_XPI_INSTALL_DIRECTORY (OPTIONAL):
+# The xpi file will be installed in the specified directory.
+# This directory must be an absolute path. Use this parameter
+# with care.
+#
# Unused variables (can be removed):
#
# MOZ_XPI_EMID (OPTIONAL):
@@ -88,6 +93,10 @@ ifneq (,$(MOZ_XPI_PRESERVE_PERMISSIONS))
install_xpi_extra_parameter += --preserve-permissions
endif
+ifneq (,$(MOZ_XPI_INSTALL_DIRECTORY))
+install_xpi_extra_parameter += -i $(MOZ_XPI_INSTALL_DIRECTORY)
+endif
+
ifeq ($(origin MOZ_XPI_DOCUMENTED_LICENSE_FILES),undefined)
install_xpi_extra_parameter += --remove-license-files
else