summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index d62dcd2..87a2b3a 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -2,6 +2,7 @@
# Copyright (c) 2008 Canonical Ltd.
# Author(s): Alexander Sack <asac@ubuntu.com>
+# Fabien Tassin <fta@sofaraway.org>
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -61,6 +62,9 @@ else
XPI_FILE = $(wildcard *.xpi)
endif
+XPI_BASE_FILE = $(notdir $(XPI_FILE))
+XPI_DIR = $(dir $(XPI_FILE))
+
ifneq (,$(MOZ_XPI_EMID))
XPI_EMID = $(MOZ_XPI_EMID)
else
@@ -84,7 +88,7 @@ endif
# ### general helper targets
stamp-unzip-%:
- unzip -d $(TEMPDIR) $*
+ unzip -d $(TEMPDIR) $(XPI_DIR)$*
touch $@
stamp-installdirs-%:
@@ -99,7 +103,7 @@ stamp-install-%: $(foreach mozilla,$(MOZ_XPI_MOZILLA_DIRS),stamp-installdirs-$(m
dh_install -p$(MOZ_EXTENSION_PKG) $(wildcard $(TEMPDIR)/*) /usr/share/$(MOZ_EXTENSION_PKG)
touch $@
-stamp-extension-install: $(XPI_FILE) stamp-unzip-$(XPI_FILE) stamp-install-$(XPI_FILE)
+stamp-extension-install: $(XPI_FILE) stamp-unzip-$(XPI_BASE_FILE) stamp-install-$(XPI_BASE_FILE)
touch $@