summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index d7e8467..5ff0977 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -70,6 +70,10 @@
# This directory must be an absolute path. Use this parameter
# with care.
#
+# MOZ_XPI_DISABLE_SYSTEM_PREFS (OPTIONAL):
+# if defined (set to 1), no system preference file will be
+# created in /etc.
+#
# Unused variables (can be removed):
#
# MOZ_XPI_EMID (OPTIONAL):
@@ -93,6 +97,10 @@ ifneq (,$(MOZ_XPI_PRESERVE_PERMISSIONS))
install_xpi_extra_parameter += --preserve-permissions
endif
+ifneq (,$(MOZ_XPI_DISABLE_SYSTEM_PREFS))
+install_xpi_extra_parameter += --disable-system-prefs
+endif
+
ifneq (,$(MOZ_XPI_INSTALL_DIRECTORY))
install_xpi_extra_parameter += -i $(MOZ_XPI_INSTALL_DIRECTORY)
endif