summaryrefslogtreecommitdiff
path: root/src/xulapp.mk.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/xulapp.mk.in')
-rw-r--r--src/xulapp.mk.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/xulapp.mk.in b/src/xulapp.mk.in
new file mode 100644
index 0000000..e0eb088
--- /dev/null
+++ b/src/xulapp.mk.in
@@ -0,0 +1,30 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
+# Description: build system for xulrunner applications
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+#####################################################################
+
+XUL_VERSION := $(shell xulrunner-1.9 --gre-version)
+
+pre-build::
+ tar zxf /usr/lib/xulrunner-devel-$(XUL_VERSION)/sdk/build-system.tar.gz
+
+clean::
+ # Drop build-system files
+ rm -rf config build
+ rm -f toolkit/xre/make-platformini.py Makefile.in configure.in aclocal.m4 allmakefiles.sh nsprpub/config/make-system-wrappers.pl