summaryrefslogtreecommitdiff
path: root/src/xulapp.mk.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/xulapp.mk.in')
-rw-r--r--src/xulapp.mk.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/xulapp.mk.in b/src/xulapp.mk.in
index e0eb088..4f7720e 100644
--- a/src/xulapp.mk.in
+++ b/src/xulapp.mk.in
@@ -21,10 +21,14 @@
XUL_VERSION := $(shell xulrunner-1.9 --gre-version)
-pre-build::
+pre-build:: build-system.stamp
+
+build-system.stamp:
tar zxf /usr/lib/xulrunner-devel-$(XUL_VERSION)/sdk/build-system.tar.gz
+ touch $@
clean::
# Drop build-system files
- rm -rf config build
- rm -f toolkit/xre/make-platformini.py Makefile.in configure.in aclocal.m4 allmakefiles.sh nsprpub/config/make-system-wrappers.pl
+ rm -rf config build toolkit nsprpub
+ rm -f Makefile.in configure.in aclocal.m4 allmakefiles.sh
+ rm -f build-system.stamp