summaryrefslogtreecommitdiff
path: root/src/xulrunner-1.9.mk.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/xulrunner-1.9.mk.in')
-rw-r--r--src/xulrunner-1.9.mk.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/src/xulrunner-1.9.mk.in b/src/xulrunner-1.9.mk.in
index 2957f8b..d5705f7 100644
--- a/src/xulrunner-1.9.mk.in
+++ b/src/xulrunner-1.9.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project XULRunner 1.9
#
# This program is free software; you can redistribute it and/or
@@ -28,11 +28,25 @@ MOZCLIENT_WANTMOZDIR := 1
include mozclient.mk.in
-COMPARE_FILTER_IN := sed \
+COMPARE_FILTER_PRE_IN = sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT = sed \
+ -e 's,^usr/share/idl/.*,,' \
+ -e 's,^usr/include/.*,,' \
+ -e 's,^usr/lib/pkgconfig/.*,,' \
+ -e 's,^usr/lib/xulrunner-devel.*,,' \
+ -e 's,^usr/lib/xulrunner-1.9[^/]*/,,' \
+ -e 's,^etc/gre.d/.*,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN = sed \
-e 's,usr/lib/xulrunner-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
-e 's,usr/lib/xulrunner-[^/]*/plugins,usr/lib/xulrunner-addons/plugins,' \
$(NULL)
-COMPARE_FILTER_OUT := sed \
+
+COMPARE_FILTER_OUT = sed \
-e 's,^DEBIAN/.*,,' \
-e 's,^usr/share/doc/.*,,' \
$(NULL)