summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index b100acc..9385a03 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -249,6 +249,10 @@ autolinks-stamp: $(patsubst %,unzip-%-stamp,$(XPI_BASE_FILE)) $(foreach mozilla,
$(if $(XPI_FILE),,@echo "xpi.mk: No xpi file found. Did you create one?"; \
echo "xpi.mk: Please check MOZ_XPI_BUILD_COMMAND and maybe MOZ_XPI_FILE!"; \
exit 2)
+ $(if $(XPI_EMID),,@echo "xpi.mk: Detecting the extension manager ID failed."; \
+ echo "xpi.mk: This is either a bug in the install.rdf file or in mozilla-devscripts."; \
+ echo "xpi.mk: Patch the install.rdf file or use MOZ_XPI_EMID as workaround."; \
+ exit 3)
$(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)),dh_link -p$(MOZ_EXTENSION_PKG) /usr/$(lib_share_dir)/$(MOZ_EXTENSION_PKG) /usr/lib/mozilla/extensions/$(id)/$(call XPI_EMID,$(TEMPDIR));)
touch $@