summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/nspr.mk.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/nspr.mk.in b/src/nspr.mk.in
index 1233245..8f8de94 100644
--- a/src/nspr.mk.in
+++ b/src/nspr.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project NSPR
#
# This program is free software; you can redistribute it and/or
@@ -21,10 +21,11 @@ MOZCLIENT_TARGET := nspr-orig
MOZCLIENT_APPNAME := nspr
MOZCLIENT_PROJECT := $(NULL)
MOZCLIENT_MODULES := mozilla/nsprpub
-MOZCLIENT_FILE := mozilla/nsprpub/configure.in
-MOZCLIENT_GETVERSION := grep -E '^MOD_(MAJOR|MINOR|PATCH)_VERSION' $(MOZCLIENT_FILE) | cut -d= -f2 | tr '\n' '.' | sed -e 's,\.$$,~,'
+MOZCLIENT_FILE := mozilla/nsprpub/pr/include/prinit.h
+MOZCLIENT_GETVERSION := grep -E '^\#define PR_VERSION' $(MOZCLIENT_FILE) | cut -d\" -f2 | tr 'A-Z' 'a-z' | sed -e 's/ */~/g' -e 's/$$/~/'
MOZCLIENT_URL := 'http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fnsprpub&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=1177522884&maxdate=1588258884&cvsroot=%2Fcvsroot'
MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | grep "href='http://webtools" | head -1 | tr '<>' '@' | cut -d@ -f5 | tr -d ':-' | sed -e 's/&nbsp;/t/'
MOZCLIENT_WANTMOZDIR := 1
+$(info $(MOZCLIENT_GETVERSION))
include mozclient.mk.in