summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index f065915..842d527 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -56,7 +56,8 @@
# defines extra license files which need to be excluded during
# the installation of the XPI file to the packaging tree. When
# using parameter, be sure that you documented _all_ excluded
-# license files in debian/copyright appropriately
+# license files in debian/copyright appropriately. If not defined
+# the common license file names are tried.
#
# Deprecated variables:
#
@@ -147,6 +148,8 @@ MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 |
MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
+MOZ_XPI_DOCUMENTED_LICENSE_FILES ?= $(strip $(shell find * -iname copying -o -iname licen[cs]e -o -iname licen[cs]e.txt))
+
XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))