summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/Makefile3
-rw-r--r--src/mozclient.mk.in3
-rw-r--r--src/patches/nspr_target.patch84
-rw-r--r--src/patches/nss_target.patch92
-rw-r--r--src/patches/series3
-rw-r--r--src/patches/xulbrowser_target.patch115
6 files changed, 299 insertions, 1 deletions
diff --git a/src/Makefile b/src/Makefile
index bf53346..7f5158a 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -40,6 +40,7 @@ extra_mk_files = \
cat $< | sed \
-e "s|^\(include\) \(.*\)\.in|\1 $(DATADIR)/\2|" \
-e "s|^\(MOZCLIENT_EXCLUDE_SCRIPT.*=[ ][ ]*\)\(.*/\)\(.*\)|\1$(DATADIR)/\3|" \
+ -e "s|^\(MOZCLIENT_PATCHES.*=[ ][ ]*\)\(.*/\)\(.*\)|\1$(DATADIR)/\3|" \
> $@
chmod 644 $@
@@ -49,6 +50,8 @@ install: $(mk_files) $(extra_mk_files)
install -m 755 -d $(DESTDIR)$(DATADIR)
install -m 644 $^ $(DESTDIR)$(DATADIR)
chmod 755 $(DESTDIR)$(DATADIR)/*.sh
+ install -m 755 -d $(DESTDIR)$(DATADIR)/patches
+ install -m 644 $(wildcard ../patches/*) $(DESTDIR)$(DATADIR)/patches
clean:
rm -f $(mk_files)
diff --git a/src/mozclient.mk.in b/src/mozclient.mk.in
index 99bfd48..acea125 100644
--- a/src/mozclient.mk.in
+++ b/src/mozclient.mk.in
@@ -80,6 +80,7 @@ MOZCLIENT_CVS_LOC = :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot
MOZCLIENT_STAMP ?= stamped
MOZCLIENT_TMP := mozclient-tmp
+MOZCLIENT_PATCHES := ../patches
MOZCLIENT_EXCLUDE_SCRIPT := ../../remove.binonly.sh
NOBINONLY := nobinonly
@@ -131,7 +132,7 @@ mozclient-patch: $(MOZCLIENT_TMP)/$(MOZCLIENT_STAMP)
$(MOZCLIENT_TMP)/$(MOZCLIENT_STAMP): $(MOZ_CLIENT)
ifeq (,$(MOZCLIENT_BRANCH))
- if [ ! -L $(MOZCLIENT_TMP)/patches ] ; then ln -s ../../patches $(MOZCLIENT_TMP)/patches ; fi
+ if [ ! -L $(MOZCLIENT_TMP)/patches ] ; then ln -s $(MOZCLIENT_PATCHES) $(MOZCLIENT_TMP)/patches ; fi
cd $(MOZCLIENT_TMP) && quilt --quiltrc /dev/null push -a || test $$? = 2
endif
touch $(MOZCLIENT_TMP)/$(MOZCLIENT_STAMP)
diff --git a/src/patches/nspr_target.patch b/src/patches/nspr_target.patch
new file mode 100644
index 0000000..1da34c9
--- /dev/null
+++ b/src/patches/nspr_target.patch
@@ -0,0 +1,84 @@
+---
+ mozilla/client.mk | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+Index: mozclient/mozilla/client.mk
+===================================================================
+--- mozclient.orig/mozilla/client.mk 2007-09-02 21:09:06.000000000 +0200
++++ mozclient/mozilla/client.mk 2007-09-02 21:09:45.000000000 +0200
+@@ -54,16 +54,17 @@
+ # export CVSROOT=:pserver:anonymous:anonymous@cvs-mirror.mozilla.org:/cvsroot
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
+ # nss
++# nspr
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+@@ -102,16 +103,17 @@
+ # MOZ_POSTFLIGHT_ALL } variables contain space-separated lists
+ # MOZ_UNIFY_BDATE - Set to use the same bdate for each project in
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
+ nss \
++ nspr \
+ suite \
+ toolkit \
+ browser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+@@ -148,16 +150,20 @@
+
+ MODULES_nss := \
+ mozilla/dbm \
+ mozilla/security/nss \
+ mozilla/security/coreconf \
+ mozilla/security/dbm \
+ $(NULL)
+
++MODULES_nspr := \
++ mozilla/nsprpub \
++ $(NULL)
++
+ MODULES_core := \
+ $(MODULES_necko) \
+ mozilla/caps \
+ mozilla/content \
+ mozilla/db/mdb \
+ mozilla/db/mork \
+ mozilla/docshell \
+ mozilla/dom \
+@@ -608,17 +614,17 @@
+ CVSCO_NSS = $(CVS) $(CVS_FLAGS) co $(NSS_CO_FLAGS) $(CVS_CO_DATE_FLAGS) $(NSS_CO_MODULE)
+ else
+ CVSCO_NSS = $(CVS) $(CVS_FLAGS) co $(NSS_CO_FLAGS) $(NSS_CO_MODULE)
+ endif
+
+ ####################################
+ # CVS defines for NSPR
+ #
+-NSPR_CO_MODULE = mozilla/nsprpub
++NSPR_CO_MODULE = $(MODULES_nspr)
+ NSPR_CO_FLAGS := -P
+ ifdef MOZ_CO_FLAGS
+ NSPR_CO_FLAGS := $(MOZ_CO_FLAGS)
+ endif
+ NSPR_CO_FLAGS := $(NSPR_CO_FLAGS) $(if $(NSPR_CO_TAG),-r $(NSPR_CO_TAG),-A)
+
+ # Can only pull the tip or branch tags by date
+ ifeq (,$(filter-out HEAD %BRANCH,$(NSPR_CO_TAG)))
diff --git a/src/patches/nss_target.patch b/src/patches/nss_target.patch
new file mode 100644
index 0000000..2965161
--- /dev/null
+++ b/src/patches/nss_target.patch
@@ -0,0 +1,92 @@
+---
+ mozilla/client.mk | 16 ++++++++++------
+ 1 file changed, 10 insertions(+), 6 deletions(-)
+
+Index: mozclient/mozilla/client.mk
+===================================================================
+--- mozclient.orig/mozilla/client.mk 2007-09-02 21:01:43.000000000 +0200
++++ mozclient/mozilla/client.mk 2007-09-02 21:03:45.000000000 +0200
+@@ -53,16 +53,17 @@
+ #
+ # export CVSROOT=:pserver:anonymous:anonymous@cvs-mirror.mozilla.org:/cvsroot
+ # export CVSROOT=:pserver:username%somedomain.org@cvs.mozilla.org:/cvsroot
+ #
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
++# nss
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+@@ -100,16 +101,17 @@
+ # MOZ_POSTFLIGHT } each project, and after all projects; these
+ # MOZ_POSTFLIGHT_ALL } variables contain space-separated lists
+ # MOZ_UNIFY_BDATE - Set to use the same bdate for each project in
+ # MOZ_BUILD_PROJECTS
+ #
+
+ AVAILABLE_PROJECTS = \
+ all \
++ nss \
+ suite \
+ toolkit \
+ browser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+@@ -139,16 +141,23 @@
+ MODULES_NS_core := \
+ $(MODULES_NS_necko) \
+ mozilla/js \
+ mozilla/js/src \
+ mozilla/js/jsd \
+ mozilla/db \
+ $(NULL)
+
++MODULES_nss := \
++ mozilla/dbm \
++ mozilla/security/nss \
++ mozilla/security/coreconf \
++ mozilla/security/dbm \
++ $(NULL)
++
+ MODULES_core := \
+ $(MODULES_necko) \
+ mozilla/caps \
+ mozilla/content \
+ mozilla/db/mdb \
+ mozilla/db/mork \
+ mozilla/docshell \
+ mozilla/dom \
+@@ -581,22 +590,17 @@
+ MOZ_MAKE := $(MAKE) $(MOZ_MAKE_FLAGS)
+ endif
+
+ endif # MOZ_BUILD_PROJECTS
+
+ ####################################
+ # CVS defines for NSS
+ #
+-NSS_CO_MODULE = \
+- mozilla/dbm \
+- mozilla/security/nss \
+- mozilla/security/coreconf \
+- mozilla/security/dbm \
+- $(NULL)
++NSS_CO_MODULE = $(MODULES_nss)
+
+ NSS_CO_FLAGS := -P
+ ifdef MOZ_CO_FLAGS
+ NSS_CO_FLAGS := $(MOZ_CO_FLAGS)
+ endif
+ NSS_CO_FLAGS := $(NSS_CO_FLAGS) $(if $(NSS_CO_TAG),-r $(NSS_CO_TAG),-A)
+
+ # Can only pull the tip or branch tags by date
diff --git a/src/patches/series b/src/patches/series
new file mode 100644
index 0000000..5f43f1b
--- /dev/null
+++ b/src/patches/series
@@ -0,0 +1,3 @@
+nss_target.patch
+nspr_target.patch
+xulbrowser_target.patch
diff --git a/src/patches/xulbrowser_target.patch b/src/patches/xulbrowser_target.patch
new file mode 100644
index 0000000..93750b3
--- /dev/null
+++ b/src/patches/xulbrowser_target.patch
@@ -0,0 +1,115 @@
+---
+ mozilla/client.mk | 37 ++++++++++++++++++++++++++++++++++---
+ 1 file changed, 34 insertions(+), 3 deletions(-)
+
+Index: mozclient/mozilla/client.mk
+===================================================================
+--- mozclient.orig/mozilla/client.mk
++++ mozclient/mozilla/client.mk
+@@ -57,16 +57,17 @@
+ # You must specify which products/modules you wish to checkout, with
+ # MOZ_CO_PROJECT and MOZ_CO_MODULE variables.
+ #
+ # MOZ_CO_PROJECT possibilities include the following:
+ # nss
+ # nspr
+ # suite (Seamonkey suite)
+ # browser (aka Firefox)
++# xulbrowser (aka Firefox using libxul from xulrunner)
+ # mail (aka Thunderbird)
+ # minimo (small browser for devices)
+ # composer (standalone composer, aka NVU)
+ # calendar (aka Sunbird, use this to build the calendar extensions also)
+ # xulrunner
+ # camino
+ # tamarin
+ #
+@@ -107,16 +108,17 @@
+
+ AVAILABLE_PROJECTS = \
+ all \
+ nss \
+ nspr \
+ suite \
+ toolkit \
+ browser \
++ xulbrowser \
+ mail \
+ minimo \
+ composer \
+ calendar \
+ xulrunner \
+ camino \
+ necko \
+ tamarin \
+@@ -272,38 +274,67 @@
+ editor/ui \
+ extensions/reporter \
+ $(NULL)
+
+ BOOTSTRAP_suite := \
+ $(BOOTSTRAP_toolkit) \
+ $(NULL)
+
++MODULES_NS_xulbrowser := \
++ $(MODULES_NS_necko) \
++ $(NULL)
++
+ MODULES_NS_browser := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
++MODULES_xulbrowser := \
++ mozilla/README \
++ mozilla/config \
++ mozilla/build \
++ mozilla/intl \
++ mozilla/modules/libpref \
++ mozilla/tools/test-harness \
++ mozilla/extensions \
++ mozilla/toolkit \
++ mozilla/xpinstall \
++ mozilla/browser \
++ mozilla/probes \
++ mozilla/other-licenses/branding/firefox \
++ mozilla/other-licenses/7zstub/firefox \
++ $(NULL)
++
+ MODULES_browser := \
+ $(MODULES_toolkit) \
+ mozilla/browser \
+ mozilla/other-licenses/branding/firefox \
+ mozilla/other-licenses/7zstub/firefox \
+ $(NULL)
+
+-LOCALES_browser := \
+- $(LOCALES_toolkit) \
++LOCALES_xulbrowser := \
+ browser \
+ extensions/reporter \
+ extensions/spellcheck \
+ other-licenses/branding/firefox \
+ $(NULL)
+
++LOCALES_browser := \
++ $(LOCALES_toolkit) \
++ $(LOCALES_xulbrowser) \
++ $(NULL)
++
++BOOTSTRAP_xulbrowser := \
++ mozilla/browser/config/version.txt \
++ mozilla/browser/config/mozconfig \
++ $(NULL)
++
+ BOOTSTRAP_browser := \
+ $(BOOTSTRAP_toolkit) \
+- mozilla/browser/config/mozconfig \
++ $(BOOTSTRAP_xulbrowser) \
+ $(NULL)
+
+ MODULES_NS_minimo := \
+ $(MODULES_NS_toolkit) \
+ $(NULL)
+
+ MODULES_minimo := \
+ $(MODULES_toolkit) \