summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/Makefile1
-rw-r--r--src/xulrunner-2.0.mk.in62
2 files changed, 63 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
index 8ed101b..c97d58b 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -32,6 +32,7 @@ mk_files = \
thunderbird-3.0.mk \
xulrunner-1.8.mk \
xulrunner-1.9.mk \
+ xulrunner-2.0.mk \
mozclient.mk \
compare.mk \
minefield-packager.mk \
diff --git a/src/xulrunner-2.0.mk.in b/src/xulrunner-2.0.mk.in
new file mode 100644
index 0000000..a29aa5f
--- /dev/null
+++ b/src/xulrunner-2.0.mk.in
@@ -0,0 +1,62 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 2.0
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_TARGET := xulrunner-2.0-orig
+MOZCLIENT_APPNAME := xulrunner-2.0
+MOZCLIENT_PROJECT := mozilla-central
+MOZCLIENT_FILE := mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_VCS := hg
+MOZCLIENT_POSTCOCMD := cd mozilla && python client.py checkout
+MOZCLIENT_URL := http://hg.mozilla.org/index.cgi/$(MOZCLIENT_PROJECT)/log
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | \
+ grep cite | head -1 | sed -e 's,.*</cite>,,' | \
+ perl -e '$$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, \
+ "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $$a = <>; \
+ $$a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { \
+ printf "%d~%04d%02d%02d\n", $$4, $$3, $$$$m{$$2}, $$1 }; '
+#MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in
+
+COMPARE_FILTER_PRE_IN = sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT = sed \
+ -e 's,^usr/share/idl/.*,,' \
+ -e 's,^usr/include/.*,,' \
+ -e 's,^usr/lib/pkgconfig/.*,,' \
+ -e 's,^usr/lib/xulrunner-devel.*,,' \
+ -e 's,^usr/lib/xulrunner-2.0[^/]*/,,' \
+ -e 's,^etc/gre.d/.*,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN = sed \
+ -e 's,usr/lib/xulrunner-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,usr/lib/xulrunner-[^/]*/plugins,usr/lib/xulrunner-addons/plugins,' \
+ $(NULL)
+
+COMPARE_FILTER_OUT = sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ $(NULL)
+
+include compare.mk.in