summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index 5d6b881..b3dd629 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -59,6 +59,10 @@
# license files in debian/copyright appropriately. If not defined
# the common license file names are tried.
#
+# MOZ_XPI_PREPACKED (OPTIONAL):
+# set this variable to 1, if the source tarball contains the xpi
+# file and if the xpi file will not be build from source
+#
# Deprecated variables:
#
# MOZ_XPI_MOZILLA_DIRS /deprecated/ (OPTIONAL/NODEFAULT - see "Note:"):
@@ -150,7 +154,9 @@ CHECK_VERSION = $(shell \
MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 | sed "s/^Package://"))
+ifneq ($(MOZ_XPI_PREPACKED),1)
MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
+endif
MOZ_XPI_DOCUMENTED_LICENSE_FILES ?= $(strip $(shell find * -iname copying -o -iname licen[cs]e -o -iname licen[cs]e.txt))