summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index fdd39ea..b100acc 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -174,8 +174,11 @@ endif
MOZ_EXT_NAME ?= $(shell echo $(MOZ_EXTENSION_PKG) | sed "s/^firefox-//;s/^iceweasel-//;s/^mozilla-//;s/^xul-ext-//")
+ifeq ($(MOZ_EXT_NAME),$(strip $(shell grep ^Source: debian/control | sed "s/^Source://")))
+ADDITIONAL_PROVIDES := $(MOZ_EXT_NAME)
+endif
strip_version = $(sort $(foreach package,$(1),$(shell echo $(package) | sed "s/-[0-9.]*$$//")))
-XPI_PROVIDES = $(sort $(filter-out $(MOZ_EXTENSION_PKG),$(MOZ_EXT_NAME) $(addsuffix -$(MOZ_EXT_NAME),xul-ext $(call strip_version,$(XPI_RECOMMENDS)))))
+XPI_PROVIDES = $(sort $(filter-out $(MOZ_EXTENSION_PKG),$(ADDITIONAL_PROVIDES) $(addsuffix -$(MOZ_EXT_NAME),xul-ext $(call strip_version,$(XPI_RECOMMENDS)))))
TEMPDIR := temp-xpi-unpacked