summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/compare.mk.in43
-rw-r--r--src/firefox-3.0.mk.in27
-rw-r--r--src/xulrunner-1.9.mk.in20
3 files changed, 69 insertions, 21 deletions
diff --git a/src/compare.mk.in b/src/compare.mk.in
index db73a8f..29cb628 100644
--- a/src/compare.mk.in
+++ b/src/compare.mk.in
@@ -23,25 +23,48 @@
# file instead, which will include this file for you.
# The following target is available to the caller:
-# compare: check the difference between what has been installed in debian/tmp
-# by the (upstream) make install rule and what has been put in the debs.
+# compare: check the difference between:
+# a/ what has been built (in dists/bin) and what has been installed (in debian/tmp)
+# b/ what has been installed (in debian/tmp) and what has been put in the debs
+# dists/bin is populated by the upstream build system
+# debian/tmp is populated according to upstream installer/package-static files
#
# The following variable are available:
-# COMPARE_FILTER_IN and COMPARE_FILTER_OUT
-# By default, both are 'sed' commands that could be augmented (+=) or
+# COMPARE_FILTER_PRE_IN and COMPARE_FILTER_PRE_OUT (for a/)
+# COMPARE_FILTER_IN and COMPARE_FILTER_OUT (for b/)
+# By default, all are 'sed' commands that could be augmented (+=) or
# overwritten by the caller.
TEMP := $(shell echo $$$$)
+LIST_BUILT := /tmp/built.$(TEMP)
LIST_INSTALLED := /tmp/installed.$(TEMP)
LIST_IN_DEBS := /tmp/in_debs.$(TEMP)
PKG_DIRS = $(addprefix debian/,$(shell grep ^Package debian/control | cut -d' ' -f2))
compare:
- @echo "## Compare..."
- @find debian/tmp -type f | cut -d/ -f3- | $(COMPARE_FILTER_IN) | sort > $(LIST_INSTALLED)
- @find $(PKG_DIRS) -type f | cut -d/ -f3- | $(COMPARE_FILTER_OUT) | sort > $(LIST_IN_DEBS)
- @-diff -u $(LIST_INSTALLED) $(LIST_IN_DEBS) | grep -E '^(\+|-).' | tail -n +3
- @rm -f $(LIST_INSTALLED) $(LIST_IN_DEBS)
+ @if [ "Z${COMPARE_FILTER_PRE_IN}Z" = "ZZ" ] ; then \
+ echo "## Can't compare dist/bin and debian/tmp (no COMPARE_FILTER_PRE_IN filter defined)" ; \
+ else \
+ if [ -d mozilla ] ; then \
+ find mozilla/dist/bin \! -type d | cut -d/ -f4- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ elif [ -d build-tree/mozilla ] ; then \
+ find build-tree/mozilla/dist/bin \! -type d | cut -d/ -f5- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ elif [ -d dist ] ; then \
+ find dist/bin \! -type d | cut -d/ -f3- | $(COMPARE_FILTER_PRE_IN) | sort > $(LIST_BUILT) ; \
+ fi ; \
+ find debian/tmp -type f | cut -d/ -f3- | $(COMPARE_FILTER_PRE_OUT) | sort > $(LIST_INSTALLED) ; \
+ echo "## Compare the content of dist/bin and debian/tmp..." ; \
+ diff -u $(LIST_BUILT) $(LIST_INSTALLED) | grep -E '^(\+|-).' | tail -n +3 ;\
+ echo "## =================================================" ; \
+ fi
+ @if [ "Z${COMPARE_FILTER_IN}Z" = "ZZ" ] ; then \
+ echo "## Can't compare debian/tmp and the debs produced (no COMPARE_FILTER_IN filter defined)" ; \
+ else \
+ echo "## Compare the content of debian/tmp and the debs produced..." ; \
+ find debian/tmp -type f | cut -d/ -f3- | $(COMPARE_FILTER_IN) | sort > $(LIST_INSTALLED) ; \
+ find $(PKG_DIRS) -type f | cut -d/ -f3- | $(COMPARE_FILTER_OUT) | sort > $(LIST_IN_DEBS) ; \
+ diff -u $(LIST_INSTALLED) $(LIST_IN_DEBS) | grep -E '^(\+|-).' | tail -n +3 ; \
+ fi
@echo "## End of Compare"
-
+ @rm -f $(LIST_BUILT) $(LIST_INSTALLED) $(LIST_IN_DEBS)
diff --git a/src/firefox-3.0.mk.in b/src/firefox-3.0.mk.in
index 8533222..a297d0c 100644
--- a/src/firefox-3.0.mk.in
+++ b/src/firefox-3.0.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project firefox 3.0
#
# This program is free software; you can redistribute it and/or
@@ -29,23 +29,34 @@ MOZCLIENT_WANTMOZDIR := 1
include mozclient.mk.in
+COMPARE_FILTER_PRE_IN := sed \
+ -e 's,foo,bar,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT := sed \
+ -e 's,^usr/lib/firefox-3.0[^/]*/,,' \
+ $(NULL)
+
COMPARE_FILTER_IN := sed \
- -e 's,^usr/lib/firefox-3.0-[^/]*/searchplugins,usr/lib/firefox-addons/searchplugins,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/extensions/inspector@mozilla.org/.*,,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/defaults/profile,etc/firefox-3.0/profile,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/\(old-homepage-default.properties\|README.txt\|removed-files\),,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/.autoreg,,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/searchplugins,usr/lib/firefox-addons/searchplugins,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/extensions/inspector@mozilla.org/.*,,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/defaults/profile,etc/firefox-3.0/profile,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/\(old-homepage-default.properties\|README.txt\|removed-files\),,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/.autoreg,,' \
+ -e 's,^etc/firefox-3.0[^/]*/.autoreg,,' \
$(NULL)
+
COMPARE_FILTER_OUT := sed \
-e 's,^DEBIAN/.*,,' \
-e 's,^usr/lib/debug/.*,,' \
-e 's,^usr/share/doc/.*,,' \
+ -e 's,^usr/share/menu/.*,,' \
-e 's,^usr/share/applications/.*,,' \
-e 's,^usr/share/bug/firefox-3.0/presubj,,' \
-e 's,^etc/firefox-3.0/\(firefoxrc\|pref/firefox.js\),,' \
-e 's,^usr/lib/firefox-addons/searchplugins/\(debsearch\|wikipedia\).\(gif\|src\),,' \
- -e 's,^usr/lib/firefox-3.0-[^/]*/\(firefox-3.0-restart-required.update-notifier\|firefox.cfg\|firefox.sh\),,' \
+ -e 's,^usr/lib/firefox-3.0[^/]*/\(firefox-3.0-restart-required.update-notifier\|firefox.cfg\|firefox.sh\|ffox-3-beta-profile-migration-dialog\),,' \
$(NULL)
include compare.mk.in
diff --git a/src/xulrunner-1.9.mk.in b/src/xulrunner-1.9.mk.in
index 2957f8b..d5705f7 100644
--- a/src/xulrunner-1.9.mk.in
+++ b/src/xulrunner-1.9.mk.in
@@ -1,6 +1,6 @@
# -*- mode: makefile; coding: utf-8 -*-
-# Copyright (c) 2007 Fabien Tassin <fta@sofaraway.org>
+# Copyright (c) 2007-2008 Fabien Tassin <fta@sofaraway.org>
# Description: Project XULRunner 1.9
#
# This program is free software; you can redistribute it and/or
@@ -28,11 +28,25 @@ MOZCLIENT_WANTMOZDIR := 1
include mozclient.mk.in
-COMPARE_FILTER_IN := sed \
+COMPARE_FILTER_PRE_IN = sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT = sed \
+ -e 's,^usr/share/idl/.*,,' \
+ -e 's,^usr/include/.*,,' \
+ -e 's,^usr/lib/pkgconfig/.*,,' \
+ -e 's,^usr/lib/xulrunner-devel.*,,' \
+ -e 's,^usr/lib/xulrunner-1.9[^/]*/,,' \
+ -e 's,^etc/gre.d/.*,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN = sed \
-e 's,usr/lib/xulrunner-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
-e 's,usr/lib/xulrunner-[^/]*/plugins,usr/lib/xulrunner-addons/plugins,' \
$(NULL)
-COMPARE_FILTER_OUT := sed \
+
+COMPARE_FILTER_OUT = sed \
-e 's,^DEBIAN/.*,,' \
-e 's,^usr/share/doc/.*,,' \
$(NULL)