summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/xpi.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index cfe2aaf..7ffd504 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -52,6 +52,11 @@
# usually xpi.mk creates the right links based on targetApplication
# parsed in install.rdf; if you need more directories, use this.
#
+# MOZ_XPI_DOCUMENTED_LICENSE_FILES (OPTIONAL):
+# defines extra license files which need to be excluded during
+# the installation of the XPI file to the packaging tree. When
+# using parameter, be sure that you documented _all_ excluded
+# license files in debian/copyright appropriately
#
# Deprecated variables:
#
@@ -180,7 +185,11 @@ endif
# ### general helper targets
stamp-unzip-%: $(XPI_FILE)
[ -d $(TEMPDIR) ] || mkdir -p $(TEMPDIR)
+ifneq (,$(MOZ_XPI_DOCUMENTED_LICENSE_FILES))
+ unzip -d $(TEMPDIR) $(XPI_DIR)$* -x $(MOZ_XPI_DOCUMENTED_LICENSE_FILES)
+else
unzip -d $(TEMPDIR) $(XPI_DIR)$*
+endif
touch $@
stamp-installlinks-%: