summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/salsa-ci.yml1
-rwxr-xr-xdebian/tests/call-programs17
-rw-r--r--debian/tests/control7
5 files changed, 32 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 85c473f..23f1212 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mtx (1.3.12-14) unstable; urgency=medium
+
+ * Update standards-version to 4.5.1.
+ * Add some simple autopkgtests (LP: #1679342)
+
+ -- Carsten Leonhardt <leo@debian.org> Sun, 10 Jan 2021 17:16:14 +0100
+
mtx (1.3.12-13) unstable; urgency=medium
* Update standards-version to 4.5.0.
diff --git a/debian/control b/debian/control
index 16a7bb0..ae1e9fc 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debian Bacula Team <pkg-bacula-devel@lists.alioth.debian.org>
Uploaders: Carsten Leonhardt <leo@debian.org>
Build-Depends: debhelper-compat (= 13), libcam-dev [kfreebsd-any]
-Standards-Version: 4.5.0
+Standards-Version: 4.5.1
Rules-Requires-Root: no
Vcs-Browser: https://salsa.debian.org/bacula-team/mtx
Vcs-Git: https://salsa.debian.org/bacula-team/mtx.git
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
index 40eb107..a37a458 100644
--- a/debian/salsa-ci.yml
+++ b/debian/salsa-ci.yml
@@ -4,5 +4,4 @@ include:
variables:
RELEASE: 'unstable'
- SALSA_CI_DISABLE_AUTOPKGTEST: 1
SALSA_CI_REPROTEST_ENABLE_DIFFOSCOPE: 1
diff --git a/debian/tests/call-programs b/debian/tests/call-programs
new file mode 100755
index 0000000..6f47dee
--- /dev/null
+++ b/debian/tests/call-programs
@@ -0,0 +1,17 @@
+#/bin/sh
+
+# Test for correct output when calling the programs
+
+set -e
+
+echo "Print mtx version:"
+mtx --version 2>&1 | grep "mtx version" && echo "... ok"
+echo ""
+
+PROGRAMS="loaderinfo scsieject scsitape tapeinfo"
+
+for p in $PROGRAMS; do
+ echo "Print $p usage:"
+ $p --nonsense 2>&1 | grep "Usage: $p" && echo "... ok"
+ echo ""
+done
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..007a57f
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,7 @@
+# Only simple tests are possible because these programs depend on a
+# (hardware) tape drive
+
+# Test if the programs run at all and print expected output
+Tests: call-programs
+Restrictions: superficial needs-root
+Depends: mtx