summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xmultistrap4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7d82b20..a23ce45 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+multistrap (2.2.8) UNRELEASED; urgency=medium
+
+ * Add missing whitespace between arguments in system() command
+
+ -- Johannes Schauer <josch@debian.org> Sat, 24 Dec 2016 02:33:48 +0100
+
multistrap (2.2.7) unstable; urgency=medium
* Since bash completion was moved away from /etc, invoke rm_conffile in
diff --git a/multistrap b/multistrap
index 5adba7c..d7955cd 100755
--- a/multistrap
+++ b/multistrap
@@ -973,7 +973,7 @@ sub native {
closedir (SEEDS);
foreach my $s (@seeds) {
printf (_g("I: Running debconf for seed file: %s\n"), $s);
- system ("$str $env chroot" . shellescape($dir) . " debconf-set-selections /tmp/preseeds/$s");
+ system ("$str $env chroot " . shellescape($dir) . " debconf-set-selections /tmp/preseeds/$s");
}
}
&run_native_hooks_start(sort @{$hooks{'N'}}) if (defined ($hooks{'N'}));
@@ -988,7 +988,7 @@ sub native {
$t =~ s/\.preinst//;
next if ($t =~ /$f/);
next if ($script =~ /bash/);
- system ("$str $env chroot" . shellescape($dir) . " /var/lib/dpkg/info/$script install");
+ system ("$str $env chroot " . shellescape($dir) . " /var/lib/dpkg/info/$script install");
}
}
my $retval = 0;