summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control2
-rw-r--r--debian/multistrap.bash-completion1
-rw-r--r--debian/multistrap.install1
-rwxr-xr-xdebian/rules2
5 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 815c3ba..4b50840 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ multistrap (2.2.2) UNRELEASED; urgency=medium
target)
* Bump debhelper compatibility level to 10
* Switch debian/rules to dh and drop cdbs
+ * Use dh_bash-completion to install bash completion script into the right
+ location (fixes lintian warning about deprecated /etc/bash_completion.d/)
-- Johannes Schauer <josch@debian.org> Fri, 02 Dec 2016 23:25:07 +0100
diff --git a/debian/control b/debian/control
index 2597f14..5fceb0f 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Johannes Schauer <josch@debian.org>
Uploaders: Wookey <wookey@debian.org>, Neil Williams <codehelp@debian.org>
Build-Depends: debhelper (>= 10)
-Build-Depends-Arch: po4a (>= 0.37.1)
+Build-Depends-Arch: po4a (>= 0.37.1), bash-completion
Build-Depends-Indep: intltool
Standards-Version: 3.9.6
Vcs-Browser: https://browse.dgit.debian.org/multistrap.git/
diff --git a/debian/multistrap.bash-completion b/debian/multistrap.bash-completion
new file mode 100644
index 0000000..434d42f
--- /dev/null
+++ b/debian/multistrap.bash-completion
@@ -0,0 +1 @@
+bash/multistrap
diff --git a/debian/multistrap.install b/debian/multistrap.install
index 5b034e6..0abedab 100644
--- a/debian/multistrap.install
+++ b/debian/multistrap.install
@@ -13,4 +13,3 @@ examples/chroot.conf ./usr/share/multistrap/
check-deps.sh ./usr/share/multistrap/
device-table.pl ./usr/share/multistrap/
update-rc.d ./usr/share/multistrap/
-bash/multistrap ./etc/bash_completion.d/
diff --git a/debian/rules b/debian/rules
index cbe925d..01c4f53 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,3 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --with bash-completion