summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2013-03-20 22:57:17 +0100
committerAndrew Shadura <bugzilla@tut.by>2013-03-20 22:57:17 +0100
commit88724d5587e4c6ff29c5dbe7ba123771572746d1 (patch)
tree3d69fbe527d07a13c405de994f0d1cb1b6c91977
parent2211f70bc7a9a7fc7a01d79711b89ca08ffe3eea (diff)
Import upstream version 0.6
-rw-r--r--ChangeLog7
-rw-r--r--README4
-rw-r--r--debian/changelog4
-rwxr-xr-xnat-traverse10
-rw-r--r--nat-traverse.110
5 files changed, 20 insertions, 15 deletions
diff --git a/ChangeLog b/ChangeLog
index f5be154..e425583 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,8 +1,13 @@
nat-traverse -- Use of UDP to traverse NAT gateways
+2012-12-24
+ * v0.6: Fixed the port forwarding example in the documentation,
+ thanks to Marcin ZajÄ…czkowski.
+
2012-02-12
* v0.5: Adjusted the length of garbage and acknowledgements packets to
- make nat-traverse work under Windows and Android.
+ make nat-traverse work under Windows and Android. Thanks to
+ Jacobo de Pedro for finding this bug!
2005-08-23
* v0.4: New option --quit-after-connect to quit nat-traverse after
diff --git a/README b/README
index c7c9fae..fcc7084 100644
--- a/README
+++ b/README
@@ -120,9 +120,9 @@ EXAMPLES
"ssh -R":
user@left $ nat-traverse 10001:natgw-of-right:10002 \
- --cmd="nc -vlp 20000"
+ --cmd="nc -vl 20000"
user@right $ nat-traverse 10002:natgw-of-left:10001 \
- --cmd="nc -vlp 22"
+ --cmd="nc -v localhost 22"
As soon as the tunnel is established (using UDP ports 10001 and 10002),
"left"'s TCP port 20000 is forwarded to "right"'s SSH Daemon (TCP port
diff --git a/debian/changelog b/debian/changelog
index f5dd671..4d9516b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-nat-traverse (0.5-1) unstable; urgency=low
+nat-traverse (0.6-1) unstable; urgency=low
* New upstream release.
* New maintainer.
@@ -11,7 +11,7 @@ nat-traverse (0.5-1) unstable; urgency=low
* Fix watch file.
* Use Architecture: all as the package is architecture-independent.
- -- Andrew O. Shadura <bugzilla@tut.by> Thu, 16 Aug 2012 18:40:32 +0200
+ -- Andrew Shadura <andrewsh@debian.org> Wed, 20 Mar 2013 22:54:50 +0100
nat-traverse (0.4-1) unstable; urgency=low
diff --git a/nat-traverse b/nat-traverse
index e887a8f..e829154 100755
--- a/nat-traverse
+++ b/nat-traverse
@@ -38,7 +38,7 @@ GetOptions(
"timeout=i" => \(my $TIMEOUT = 10),
"quit-after-connect" => \my $QUIT_AFTER_CONNECT,
"cmd=s" => \my $CMD,
- "version" => sub { print "nat-traverse 0.5\n"; exit },
+ "version" => sub { print "nat-traverse 0.6\n"; exit },
"help" => \&usage,
) or usage();
usage() unless @ARGV == 1;
@@ -155,7 +155,7 @@ if(defined $CMD) {
# Display usage info.
sub usage { print STDERR <<'USAGE'; exit }
-nat-traverse v0.5 -- Use of UDP to traverse NAT gateways
+nat-traverse v0.6 -- Use of UDP to traverse NAT gateways
Usage:
user@left $ nat-traverse [options] port1:natgw-of-right:port2
@@ -201,7 +201,7 @@ C<right>. See L</EXAMPLES> for more.
=head1 VERSION
-This document describes nat-traverse v0.5.
+This document describes nat-traverse v0.6.
=head1 DESCRIPTION
@@ -328,9 +328,9 @@ arbitrary UDP or TCP port of the remote host, similar to C<ssh -L> or C<ssh
-R>:
user@left $ nat-traverse 10001:natgw-of-right:10002 \
- --cmd="nc -vlp 20000"
+ --cmd="nc -vl 20000"
user@right $ nat-traverse 10002:natgw-of-left:10001 \
- --cmd="nc -vlp 22"
+ --cmd="nc -v localhost 22"
As soon as the tunnel is established (using UDP ports C<10001> and C<10002>),
C<left>'s TCP port C<20000> is forwarded to C<right>'s SSH Daemon (TCP port
diff --git a/nat-traverse.1 b/nat-traverse.1
index 2e5bfa0..76700c8 100644
--- a/nat-traverse.1
+++ b/nat-traverse.1
@@ -1,4 +1,4 @@
-.\" Automatically generated by Pod::Man 2.1801 (Pod::Simple 3.07)
+.\" Automatically generated by Pod::Man 2.22 (Pod::Simple 3.14)
.\"
.\" Standard preamble:
.\" ========================================================================
@@ -123,8 +123,8 @@
.rm #[ #] #H #V #F C
.\" ========================================================================
.\"
-.IX Title "NAT-TRAVERSE 1"
-.TH NAT-TRAVERSE 1 "2012-02-12" "perl v5.10.0" "User Contributed Perl Documentation"
+.IX Title "NAT-TRAVERSE-0.6 1"
+.TH NAT-TRAVERSE-0.6 1 "2012-12-24" "perl v5.10.1" "User Contributed Perl Documentation"
.\" For nroff, turn off justification. Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.if n .ad l
@@ -255,9 +255,9 @@ arbitrary \s-1UDP\s0 or \s-1TCP\s0 port of the remote host, similar to \f(CW\*(C
.PP
.Vb 4
\& user@left $ nat\-traverse 10001:natgw\-of\-right:10002 \e
-\& \-\-cmd="nc \-vlp 20000"
+\& \-\-cmd="nc \-vl 20000"
\& user@right $ nat\-traverse 10002:natgw\-of\-left:10001 \e
-\& \-\-cmd="nc \-vlp 22"
+\& \-\-cmd="nc \-v localhost 22"
.Ve
.PP
As soon as the tunnel is established (using \s-1UDP\s0 ports \f(CW10001\fR and \f(CW10002\fR),