summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-02-06 22:38:28 -0500
committerAaron M. Ucko <ucko@debian.org>2019-02-06 22:39:13 -0500
commit53ca0250e80ae069a17356799006815dd528f5a0 (patch)
tree40d71ca3860058203bb65f149e51357eb096adac
parent0ff7f663a44588878c235db6c17b44eac0def17e (diff)
parent492cba4e7c2d8c9ef3a853fd24e062df6cb08aaa (diff)
Merge tag 'upstream/10.9.20190131+ds'
Upstream version 10.9.20190131(+ds).
-rw-r--r--debian/changelog4
-rwxr-xr-xedirect.pl2
-rwxr-xr-xnquire81
-rw-r--r--rchive.go2
-rwxr-xr-xtransmute2
-rw-r--r--xtract.go28
6 files changed, 94 insertions, 25 deletions
diff --git a/debian/changelog b/debian/changelog
index b3e653f..31303aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-ncbi-entrez-direct (10.8.20190128+ds-1) UNRELEASED; urgency=medium
+ncbi-entrez-direct (10.9.20190131+ds-1) UNRELEASED; urgency=medium
* New upstream release. (NOT RELEASED YET.)
* debian/man/{archive-pubmed,download-pubmed,edirect,efilter,
@@ -10,7 +10,7 @@ ncbi-entrez-direct (10.8.20190128+ds-1) UNRELEASED; urgency=medium
* debian/rules: Stop installing retired scripts local-phrase-search and
(implicitly) pm-{clean,current,erase,log,repack,uids,verify}.
- -- Aaron M. Ucko <ucko@debian.org> Wed, 06 Feb 2019 22:36:07 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Wed, 06 Feb 2019 22:38:28 -0500
ncbi-entrez-direct (10.5.20181204+ds-2) unstable; urgency=medium
diff --git a/edirect.pl b/edirect.pl
index d031584..69681d1 100755
--- a/edirect.pl
+++ b/edirect.pl
@@ -43,7 +43,7 @@ use File::Spec;
# EDirect version number
-$version = "10.8";
+$version = "10.9";
BEGIN
{
diff --git a/nquire b/nquire
index b63d295..a48c3f5 100755
--- a/nquire
+++ b/nquire
@@ -43,7 +43,7 @@ use File::Spec;
# nquire version number
-$version = "10.8";
+$version = "10.9";
BEGIN
{
@@ -571,7 +571,7 @@ sub nquire {
}
}
- # if present, -http get or -get must be next
+ # if present, -http get or -get must be next (now also allow -http post or -post)
# nquire -get -url "http://collections.mnh.si.edu/services/resolver/resolver.php" -voucher "Birds:625456"
@@ -586,6 +586,9 @@ sub nquire {
} elsif ( $pat eq "-get" ) {
$i++;
$http = "get";
+ } elsif ( $pat eq "-post" ) {
+ $i++;
+ $http = "post";
}
}
@@ -653,6 +656,31 @@ sub nquire {
if ( $i < $max ) {
$url = "http://qa.ncbi.nlm.nih.gov/entrez/eutils";
}
+
+ } elsif ( $pat eq "-hydra" ) {
+ # internal citation match request (undocumented)
+ $i++;
+ if ( $i < $max ) {
+ $url = "https://www.ncbi.nlm.nih.gov/projects/hydra/hydra_search.cgi";
+ $pat = $args[$i];
+ $pat = map_macros ($pat);
+ $enc = do_uri_escape ($pat);
+ $arg="search=pubmed_search_citation_top_20.1&query=$enc";
+ $amp = "&";
+ $i++;
+ }
+
+ } elsif ( $pat eq "-revhist" ) {
+ # internal sequence revision history request (undocumented)
+ $i++;
+ if ( $i < $max ) {
+ $url = "https://www.ncbi.nlm.nih.gov/sviewer/girevhist.cgi";
+ $pat = $args[$i];
+ $arg="cmd=seqid&txt=on&seqid=asntext&os=PUBSEQ_OS&val=$pat";
+ $amp = "&";
+ $i++;
+ }
+
} elsif ( $pat eq "-pubchem" ) {
# shortcut for PubChem Power User Gateway REST service base (undocumented)
# nquire -pubchem "compound/name/creatine/property" "IUPACName,MolecularWeight,MolecularFormula" "XML"
@@ -676,28 +704,45 @@ sub nquire {
}
}
}
- } elsif ( $pat eq "-hydra" ) {
- # internal citation match request (undocumented)
+
+ } elsif ( $pat eq "-mygene" or $pat eq "-mygene.info" ) {
+ # shortcut for mygene.info (undocumented)
$i++;
if ( $i < $max ) {
- $url = "https://www.ncbi.nlm.nih.gov/projects/hydra/hydra_search.cgi";
- $pat = $args[$i];
- $pat = map_macros ($pat);
- $enc = do_uri_escape ($pat);
- $arg="search=pubmed_search_citation_top_20.1&query=$enc";
- $amp = "&";
- $i++;
+ $url = "http://mygene.info/v3";
+ if ( $http eq "" ) {
+ $http = "get";
+ }
}
- } elsif ( $pat eq "-revhist" ) {
- # internal sequence revision history request (undocumented)
+ } elsif ( $pat eq "-myvariant" or $pat eq "-myvariant.info" ) {
+ # shortcut for myvariant.info (undocumented)
$i++;
if ( $i < $max ) {
- $url = "https://www.ncbi.nlm.nih.gov/sviewer/girevhist.cgi";
- $pat = $args[$i];
- $arg="cmd=seqid&txt=on&seqid=asntext&os=PUBSEQ_OS&val=$pat";
- $amp = "&";
- $i++;
+ $url = "http://myvariant.info/v1";
+ if ( $http eq "" ) {
+ $http = "get";
+ }
+ }
+ } elsif ( $pat eq "-mychem" or $pat eq "-mychem.info" ) {
+ # shortcut for mychem.info (undocumented)
+ $i++;
+ if ( $i < $max ) {
+ $url = "http://mychem.info/v1";
+ if ( $http eq "" ) {
+ $http = "get";
+ }
}
+
+ } elsif ( $pat eq "-wikipathways" ) {
+ # shortcut for webservice.wikipathways.org (undocumented)
+ $i++;
+ if ( $i < $max ) {
+ $url = "http://webservice.wikipathways.org";
+ if ( $http eq "" ) {
+ $http = "get";
+ }
+ }
+
} elsif ( $pat eq "-biosample" ) {
# internal biosample_chk request on live database (undocumented)
$i++;
diff --git a/rchive.go b/rchive.go
index c5114e0..a49eb12 100644
--- a/rchive.go
+++ b/rchive.go
@@ -62,7 +62,7 @@ import (
// RCHIVE VERSION AND HELP MESSAGE TEXT
-const rchiveVersion = "10.8"
+const rchiveVersion = "10.9"
const rchiveHelp = `
Processing Flags
diff --git a/transmute b/transmute
index 36dba33..d142738 100755
--- a/transmute
+++ b/transmute
@@ -43,7 +43,7 @@ use File::Spec;
# transmute version number
-$version = "10.8";
+$version = "10.9";
BEGIN
{
diff --git a/xtract.go b/xtract.go
index dfd540a..7813d24 100644
--- a/xtract.go
+++ b/xtract.go
@@ -53,7 +53,7 @@ import (
// XTRACT VERSION AND HELP MESSAGE TEXT
-const xtractVersion = "10.8"
+const xtractVersion = "10.9"
const xtractHelp = `
Overview
@@ -5764,7 +5764,7 @@ func ProcessINSD(args []string, isPipe, addDash, doIndex bool) []string {
acc = append(acc, "-element", "INSDSeq_accession-version", "-clr", "-rst", "-tab", "\\n")
}
} else {
- acc = append(acc, "-pattern", "INSDSeq", "-ACCN", "INSDSeq_accession-version")
+ acc = append(acc, "-pattern", "INSDSeq", "-ACCN", "INSDSeq_accession-version", "-SEQ", "INSDSeq_sequence")
}
if doIndex {
@@ -5935,6 +5935,30 @@ func ProcessINSD(args []string, isPipe, addDash, doIndex bool) []string {
// report capitalization or vocabulary failure
checkAgainstVocabulary(str, "element", insdtags)
+ } else if str == "sub_sequence" {
+
+ // special sub_sequence qualifier shows sequence under feature intervals
+ acc = append(acc, "-block", "INSDFeature_intervals")
+ if isPipe {
+ acc = append(acc, "-lbl", "")
+ } else {
+ acc = append(acc, "-lbl", "\"\"")
+ }
+
+ acc = append(acc, "-subset", "INSDInterval", "-FR", "INSDInterval_from", "-TO", "INSDInterval_to")
+ if isPipe {
+ acc = append(acc, "-pfx", "", "-tab", "", "-nucleic", "&SEQ[&FR:&TO]")
+ } else {
+ acc = append(acc, "-pfx", "\"\"", "-tab", "\"\"", "-nucleic", "\"&SEQ[&FR:&TO]\"")
+ }
+
+ acc = append(acc, "-subset", "INSDFeature_intervals")
+ if isPipe {
+ acc = append(acc, "-lbl", "\\t")
+ } else {
+ acc = append(acc, "-lbl", "\"\\t\"")
+ }
+
} else {
acc = append(acc, "-block", "INSDQualifier")