summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2020-04-28 20:27:03 -0400
committerAaron M. Ucko <ucko@debian.org>2020-06-21 21:42:13 -0400
commite1d2e2522afe445d0d07a3e07fe5dc8ea972ce12 (patch)
treee71c9ab9effbbe99fc63d66e605964246e3bc38a /debian
parentad47134d33bd6dc19a237481200d51983690638a (diff)
Tweak installation structure so xtract can find hlp-xtract.txt.
* Generally change /usr/share/ncbi-entrez-direct to /usr/lib/n-e-d. * debian/install: Install hlp-*.txt (hlp-xtract.txt) there too. * debian/rules: - Adjust corresponding macro name from SHARE_DIR to LIB_DIR accordingly. - Move the xtract binary there from /usr/bin (so it can find hlp-xtract.txt) and substitute a wrapper script.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/install3
-rwxr-xr-xdebian/rules11
3 files changed, 23 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 66bc49e..85d67f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,8 @@ ncbi-entrez-direct (12.8.20191206+dfsg-1) unstable; urgency=medium
* debian/copyright: Add *.pdf (sourceless) to Files-Excluded.
* debian/examples: Remove Scripps BioThings support, now considered official
enough (mentioned in README, albeit as experimental).
- * debian/install: Install bt-*.txt (bt-context.txt at present) to a new
- /usr/share/ncbi-entrez-direct directory.
+ * debian/install: Install bt-*.txt and hlp-*.txt (bt-context.txt and
+ hlp-xtract.txt at present) to a new /usr/lib/ncbi-entrez-direct directory.
* debian/man/{archive-pubmed,download-ncbi-data,edirect,efetch,elink,esample,
esearch,ftp-cp,fetch-pubmed,ftp-ls,index-pubmed,j2x,join-into-groups-of,
nquire,phrase-search,rchive,transmute,xtract}.1: Update for new release.
@@ -18,17 +18,19 @@ ncbi-entrez-direct (12.8.20191206+dfsg-1) unstable; urgency=medium
* debian/man/nquire.1: Belatedly drop accidental self-referential SEE ALSO.
* debian/man/xtract.1: Explicitly mark suboptions as such; belatedly resync
-indices' description.
- * debian/rules: Account for new as-is scripts expand-current and
- fetch-extras; for newly official Scripps BioThings scripts bt-link,
- bt-load, bt-save, bt-srch, and xplore (some of which need tweaking to look
- for bt-context.txt in the right place); for new Go executable t2x; and for
- rename of as-is script index-bioc to index-extras (which moreover needs
- its interpreter specification corrected to #!/bin/bash via a new generic
- mechanism).
+ * debian/rules:
+ - Account for new as-is scripts expand-current and fetch-extras; for newly
+ official Scripps BioThings scripts bt-link, bt-load, bt-save, bt-srch,
+ and xplore (some of which need tweaking to look for bt-context.txt in the
+ right place); for new Go executable t2x; and for rename of as-is script
+ index-bioc to index-extras (which moreover needs its interpreter
+ specification corrected to #!/bin/bash via a new generic mechanism).
+ - Move the xtract binary from /usr/bin to /usr/lib/ncbi-entrez-direct (so
+ it can find hlp-xtract.txt) and substitute a wrapper script.
* debian/watch: Change repack suffix to +dfsg due to the additional need
to exclude sourceless PDF documents.
- -- Aaron M. Ucko <ucko@debian.org> Tue, 28 Apr 2020 20:04:15 -0400
+ -- Aaron M. Ucko <ucko@debian.org> Tue, 28 Apr 2020 20:27:02 -0400
ncbi-entrez-direct (12.0.20190816+ds-2) unstable; urgency=medium
diff --git a/debian/install b/debian/install
index 8bf250c..ad76361 100644
--- a/debian/install
+++ b/debian/install
@@ -1,2 +1,3 @@
bin/* usr/bin
-bt-*.txt usr/share/ncbi-entrez-direct
+bt-*.txt usr/lib/ncbi-entrez-direct
+hlp-*.txt usr/lib/ncbi-entrez-direct
diff --git a/debian/rules b/debian/rules
index ff935bf..7eadbed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ include /usr/share/dpkg/default.mk
dh $@ --with=golang
PACKAGE = ncbi-entrez-direct
-SHARE_DIR = /usr/share/$(PACKAGE)
+LIB_DIR = /usr/lib/$(PACKAGE)
MODES = address blast citmatch contact filter link notify post proxy search \
spell
@@ -99,7 +99,7 @@ $(BIN_DL_SCRIPTS): bin/%: %
$(BIN_BT_SCRIPTS): bin/%: %
mkdir -p bin
- sed -e 's,"*\$$dir"*\(/bt-[^ .]*\.txt\)"*,$(SHARE_DIR)\1,g' $< > $@
+ sed -e 's,"*\$$dir"*\(/bt-[^ .]*\.txt\)"*,$(LIB_DIR)\1,g' $< > $@
chmod +x $@
$(GOPATH)/src/$(GH)/fiam/gounidecode: $(GOLIBS)
@@ -119,6 +119,13 @@ override_dh_auto_build: $(WRAPPERS) $(BIN_BASH_SCRIPTS) $(BIN_DL_SCRIPTS) \
dh_auto_build
install $(AS_IS_SCRIPTS) debian/efetch debian/einfo bin/
+override_dh_install:
+ dh_install
+ mv debian/$(PACKAGE)/usr/bin/xtract debian/$(PACKAGE)/$(LIB_DIR)/
+ printf '#!/bin/sh\nexec $(LIB_DIR)/xtract "$$@"\n' \
+ > debian/$(PACKAGE)/usr/bin/xtract
+ chmod +x debian/$(PACKAGE)/usr/bin/xtract
+
override_dh_installexamples:
dh_installexamples
sed -i '$(FIX_PERL_SHEBANG)' debian/*/usr/share/doc/*/examples/*