summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKexy Biscuit <kexybiscuit@outlook.com>2019-10-03 04:37:18 +0800
committerAndrej Shadura <andrewsh@debian.org>2019-11-01 15:21:21 +0100
commite4e25730afcee44035d1bd1eba03ff81ac6a8f20 (patch)
tree77b10645275f61d841efaf8589a7558449d3d729
parent5753510f284571b5fad75844a420d6fcdec3741c (diff)
[PATCH 2/3] Makefile: fix escaping in _features.h (#103)
Gbp-Pq: Name 0002-Makefile-fix-escaping-in-_features.h-103.patch
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d89eb26..c9921ed 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ netplan-dbus: src/dbus.c src/_features.h
$(CC) $(BUILDFLAGS) $(CFLAGS) -o $@ $^ `pkg-config --cflags --libs libsystemd glib-2.0`
src/_features.h: src/[^_]*.[hc]
- echo "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {" > $@
+ printf "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {\n" > $@
awk 'match ($$0, /netplan-feature:.*/ ) { $$0=substr($$0, RSTART, RLENGTH); print "\""$$2"\"," }' $^ >> $@
echo "NULL, };" >> $@