summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-12-09 21:55:38 -0400
committerDavid Bremner <david@tethera.net>2020-12-09 21:55:38 -0400
commited7ca948ae31ac0e1d3633a2f58fb3e4aecd03de (patch)
tree84494458e6568b45d879d5b07a8014131bc15592
parent900ee94b0f4f48ee536bd2e9bd6bb2dfc661d615 (diff)
build/docs: move docstring prereq to file targets
Under a sufficiently high level of parallelism [1] there seems to be a a race condition that allows sphinx-build to start running before the docstrings are extracted. This change moves the docstring stamp from the phony targets sphinx-html and sphinx-info to the file targets that they depend on. I'm not sure why this makes things better, but I am fairly confident it does not make things worse, and experimentally it seems to eliminate the race condition. [1]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=976934
-rw-r--r--doc/Makefile.local2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index 60bd7184..f476d1da 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -43,7 +43,7 @@ INFO_INFO_FILES := $(INFO_TEXI_FILES:.texi=.info)
rm -f $@ && gzip --no-name --stdout $^ > $@
ifeq ($(WITH_EMACS),1)
-$(DOCBUILDDIR)/.roff.stamp sphinx-html sphinx-texinfo: docstring.stamp
+$(DOCBUILDDIR)/.roff.stamp $(DOCBUILDDIR)/.html.stamp $(DOCBUILDDIR)/.texi.stamp : docstring.stamp
endif
sphinx-html: $(DOCBUILDDIR)/.html.stamp