summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2022-04-15 09:17:30 -0300
committerDavid Bremner <david@tethera.net>2022-04-15 09:23:58 -0300
commit78aaef9a0b6f106e648367b18b46b48d885f9213 (patch)
tree33322e56e2b298b0cf5ee634a9f6714c34dbb33a
parent83f4e5babb61e56f34d2f8baf1aa15a84cfb25a2 (diff)
release: automate upload of pre-release tarballsdebian/0.36_rc0-1archive/debian/0.36_rc0-1
The tarballs were requested by some distro-packagers, and this automation will hopefully reduce the number of errors from the current manual process.
-rw-r--r--Makefile.local4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.local b/Makefile.local
index bbc464d2..d8bbf3e1 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -93,6 +93,10 @@ pre-release:
pristine-tar commit $(DEB_TAR_FILE) $(UPSTREAM_TAG)
mkdir -p releases
mv $(TAR_FILE) $(DEB_TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) releases
+ifeq ($(REALLY_UPLOAD),yes)
+ git push origin $(UPSTREAM_TAG) release pristine-tar
+ cd releases && scp $(TAR_FILE) $(SHA256_FILE) $(DETACHED_SIG_FILE) $(RELEASE_HOST):$(RELEASE_DIR)
+endif
.PHONY: debian-snapshot
debian-snapshot: