summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2020-11-08 10:08:00 -0400
committerDavid Bremner <david@tethera.net>2020-11-08 10:08:00 -0400
commitc5504cb04398eeeb595cfebe84714ba982ef00e6 (patch)
treef1271553ddf2a688b516b739058e50dbd6ced14b
parent40b75f50be35dd372547bf03b972059e88b6f19b (diff)
Commit Debian 3.0 (quilt) metadatadebian/0.31.1-1archive/debian/0.31.1-1
[dgit (9.12) quilt-fixup]
-rw-r--r--debian/patches/debian-changes34
-rw-r--r--debian/patches/series1
2 files changed, 35 insertions, 0 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 00000000..de0f871b
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,34 @@
+This is an autogenerated patch header for a single-debian-patch file. The
+delta against upstream is either kept as a single patch, or maintained
+in some VCS, and exported as a single patch instead of more manageable
+atomic patches.
+
+--- notmuch-0.31.1.orig/devel/release-checks.sh
++++ notmuch-0.31.1/devel/release-checks.sh
+@@ -29,7 +29,7 @@ append_emsg ()
+ emsgs="${emsgs:+$emsgs\n} $1"
+ }
+
+-for f in ./version debian/changelog NEWS "$PV_FILE"
++for f in ./version.txt debian/changelog NEWS "$PV_FILE"
+ do
+ if [ ! -f "$f" ]; then append_emsg "File '$f' is missing"
+ elif [ ! -r "$f" ]; then append_emsg "File '$f' is unreadable"
+@@ -53,7 +53,7 @@ then
+ else
+ echo "Reading './version' file failed (surprisingly!)"
+ exit 1
+-fi < ./version
++fi < ./version.txt
+
+ readonly VERSION
+
+@@ -109,7 +109,7 @@ else
+ fi
+
+ echo -n "Checking that python bindings version is $VERSION... "
+-py_version=`python -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
++py_version=`python3 -c "with open('$PV_FILE') as vf: exec(vf.read()); print(__VERSION__)"`
+ if [ "$py_version" = "$VERSION" ]
+ then
+ echo Yes.
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..7bb82529
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian-changes