summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-06-10 21:06:57 -0300
committerDavid Bremner <david@tethera.net>2019-06-10 21:46:55 -0300
commit71bf459596c72cf72b89c6ae2f47b1f5cf7548db (patch)
treea1f6371aa057fc4182d73884f605301f5bd34d06
parent3d9edf4fb16dbc2ad3db325c62e1d4ff8887fcac (diff)
doc: don't build notmuch-emacs.info for configure --without-emacs
Since the docstrings are not built in the case of --without-emacs, even if emacs is detected, don't let sphinx build the emacs docs. This avoids a large number of error messages due to missing includes. It's actually a bit surprising sphinx doesn't generate an error for the missing include files.
-rw-r--r--doc/Makefile.local2
-rw-r--r--doc/conf.py7
2 files changed, 5 insertions, 4 deletions
diff --git a/doc/Makefile.local b/doc/Makefile.local
index 719172fe..a88beb46 100644
--- a/doc/Makefile.local
+++ b/doc/Makefile.local
@@ -4,7 +4,7 @@ dir := doc
# You can set these variables from the command line.
SPHINXOPTS := -q
-SPHINXBUILD = HAVE_EMACS=${HAVE_EMACS} sphinx-build
+SPHINXBUILD = HAVE_EMACS=${HAVE_EMACS} WITH_EMACS=${WITH_EMACS} sphinx-build
DOCBUILDDIR := $(dir)/_build
# Internal variables.
diff --git a/doc/conf.py b/doc/conf.py
index 5f8c9f1c..8afff929 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -29,9 +29,10 @@ release = version
# directories to ignore when looking for source files.
exclude_patterns = ['_build']
-# If we don't have emacs, don't build the notmuch-emacs docs, as they need
-# emacs to generate the docstring include files
-if os.environ.get('HAVE_EMACS') != '1':
+# If we don't have emacs (or the user configured --without-emacs),
+# don't build the notmuch-emacs docs, as they need emacs to generate
+# the docstring include files
+if os.environ.get('HAVE_EMACS') != '1' or os.environ.get('WITH_EMACS') != '1':
exclude_patterns.append('notmuch-emacs.rst')
# The name of the Pygments (syntax highlighting) style to use.