summaryrefslogtreecommitdiff
path: root/Makefile.global
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2017-03-14 08:10:07 -0300
committerDavid Bremner <david@tethera.net>2017-03-18 21:37:43 -0300
commitc39f6361d0798aa8d0dcd0b91f6b86ab9dc21c75 (patch)
tree6e62c880186ea60974847f525b253c670f6c851b /Makefile.global
parenta8a270522231b186493ecd97d56a1343382d51d8 (diff)
rename libutil.a to libnotmuch_util.a
Apparently some systems (MacOS?) have a system library called libutil and the name conflict causes problems. Since this library is quite notmuch specific, rename it to something less generic.
Diffstat (limited to 'Makefile.global')
-rw-r--r--Makefile.global2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.global b/Makefile.global
index 7a78e9b5..cae4c7d1 100644
--- a/Makefile.global
+++ b/Makefile.global
@@ -52,7 +52,7 @@ PV_FILE=bindings/python/notmuch/version.py
STD_CFLAGS := -std=gnu99
FINAL_CFLAGS = -DNOTMUCH_VERSION=$(VERSION) $(CPPFLAGS) $(STD_CFLAGS) $(CFLAGS) $(WARN_CFLAGS) $(extra_cflags) $(CONFIGURE_CFLAGS)
FINAL_CXXFLAGS = $(CPPFLAGS) $(CXXFLAGS) $(WARN_CXXFLAGS) $(extra_cflags) $(extra_cxxflags) $(CONFIGURE_CXXFLAGS)
-FINAL_NOTMUCH_LDFLAGS = $(LDFLAGS) -Lutil -lutil -Llib -lnotmuch
+FINAL_NOTMUCH_LDFLAGS = $(LDFLAGS) -Lutil -lnotmuch_util -Llib -lnotmuch
ifeq ($(LIBDIR_IN_LDCONFIG),0)
FINAL_NOTMUCH_LDFLAGS += $(RPATH_LDFLAGS)
endif