summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules7
3 files changed, 16 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index d0af208..27d8d93 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+nsis (3.09-3) unstable; urgency=medium
+
+ * Use common options for nsis-doc installation
+ * Added Breaks+Replaces fields to facilitate move of plugin example
+ (Closes: #1060310)
+ * Remove the disable reloc flag that is set by SCons
+ * Exclude Debian revison suffix from VER_REVISION
+
+ -- Thomas Gaugler <thomas@dadie.net> Sun, 28 Jan 2024 11:58:35 +0100
+
nsis (3.09-2) unstable; urgency=medium
* Bump Standards-Version to 4.6.2 (no changes needed)
diff --git a/debian/control b/debian/control
index 6e2589c..808754d 100644
--- a/debian/control
+++ b/debian/control
@@ -53,6 +53,9 @@ Architecture: all
Multi-Arch: foreign
Depends: ${misc:Depends}
Recommends: mingw-w64
+Replaces: nsis-doc (<< 3.09-2)
+Breaks: nsis-doc (<< 3.09-2)
+Suggests: nsis-doc (>= 3.09-2)
Enhances: nsis (>= ${source:Version})
Description: Nullsoft Scriptable Install System plugin API
NSIS is a tool for creating quick and user friendly installers for
diff --git a/debian/rules b/debian/rules
index a95411a..b10ef30 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,7 +28,7 @@ endef
VERSION_DECOMPOSED=$(call SPLIT,$(VERSION),. - + ~)
VER_MAJOR=$(firstword $(VERSION_DECOMPOSED))
VER_MINOR=$(word 2,$(VERSION_DECOMPOSED))
-VER_REVISION=$(word 3,$(VERSION_DECOMPOSED))
+VER_REVISION=$(firstword $(subst +, ,$(word 3,$(VERSION_DECOMPOSED))))
# Variables for Win32/Win64 cross compiler
XGCC_W32_X86 = i686-w64-mingw32-gcc
@@ -103,8 +103,7 @@ IGNORE_UTILS_COMMON := $(subst $(COMMA)UIs,,$(IGNORE_UTILS_COMMON))
SCONSOPTS_HOST := $(SCONSHOSTFLAGS) $(SCONSOPTS) \
SKIPPLUGINS=all SKIPSTUBS=all \
SKIPUTILS=$(IGNORE_UTILS_NSIS) SKIPDOC=COPYING
-SCONSOPTS_COMMON := APPEND_LINKFLAGS="--disable-reloc-section" \
- $(SCONSOPTS) SKIPUTILS=$(IGNORE_UTILS_COMMON) \
+SCONSOPTS_COMMON := $(SCONSOPTS) SKIPUTILS=$(IGNORE_UTILS_COMMON) \
SKIPDOC=COPYING
INSTALL_nsis = install-utils install-compiler install-conf
@@ -114,7 +113,7 @@ INSTALL_FLAGS_nsis-common = $(SCONSOPTS_COMMON)
INSTALL_nsis-pluginapi = install-pluginapi
INSTALL_FLAGS_nsis-pluginapi = $(SCONSOPTS_COMMON)
INSTALL_nsis-doc = install-examples install-doc install-docs
-INSTALL_FLAGS_nsis-doc = $(SCONSHOSTFLAGS) $(SCONSOPTS) \
+INSTALL_FLAGS_nsis-doc = $(SCONSOPTS_COMMON) \
SKIPPLUGINS=ExDLL SKIPSTUBS=all SKIPUTILS=$(IGNORE_UTILS_COMMON) \
SKIPDOC=COPYING