summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBruce Guenter <bruce@untroubled.org>2000-02-17 00:24:45 +0000
committerBruce Guenter <bruce@untroubled.org>2000-02-17 00:24:45 +0000
commite2dc08d88ac995de9541b544b88e46e393a7079a (patch)
tree3f8a6075b2516306c11e982a398de07e75aaba16 /src/Makefile.am
Imported sources.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..31f59c7
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,28 @@
+bin_PROGRAMS = \
+ mailq \
+ nullmailer-inject
+sbin_PROGRAMS = \
+ nullmailer-queue \
+ nullmailer-send \
+ sendmail
+
+#noinst_PROGRAMS = address
+
+CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
+INCLUDES = -I../lib -I../lib/cli
+
+mailq_SOURCES = mailq.cc
+mailq_LDADD = ../lib/libnullmailer.a
+
+nullmailer_inject_SOURCES = inject.cc
+nullmailer_inject_LDADD = ../lib/cli/libcli.a ../lib/libnullmailer.a
+
+nullmailer_queue_SOURCES = queue.cc
+nullmailer_queue_LDADD = ../lib/libnullmailer.a
+
+nullmailer_send_SOURCES = send.cc
+nullmailer_send_LDADD = ../lib/libnullmailer.a
+
+sendmail_SOURCES = sendmail.cc
+sendmail_LDADD = ../lib/cli/libcli.a ../lib/libnullmailer.a
+