summaryrefslogtreecommitdiff
path: root/lib/fdbuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/fdbuf/Makefile.am')
-rw-r--r--lib/fdbuf/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/lib/fdbuf/Makefile.am b/lib/fdbuf/Makefile.am
new file mode 100644
index 0000000..152d634
--- /dev/null
+++ b/lib/fdbuf/Makefile.am
@@ -0,0 +1,29 @@
+noinst_LIBRARIES = libfdbuf.a
+AM_CPPFLAGS = -I$(top_srcdir)/lib
+
+if FDBUF_NO_MYSTRING
+mystring_sources =
+else
+mystring_sources = fdibuf_mystring.cc fdibuf_netstring.cc
+endif
+
+if TLS
+tls_sources = tlsibuf.h tlsibuf.cc tlsobuf.h tlsobuf.cc
+else
+tls_sources =
+endif
+
+libfdbuf_a_SOURCES = \
+ fdbuf.h \
+ fdbuf.cc \
+ fdbuf_copy.cc \
+ fdibuf.h \
+ fdibuf.cc \
+ fdobuf.h \
+ fdobuf.cc \
+ fdobuf_chownmod.cc \
+ fdobuf_seek.cc \
+ fdobuf_signed.cc \
+ fdobuf_unsigned.cc \
+ $(tls_sources) \
+ $(mystring_sources)