summaryrefslogtreecommitdiff
path: root/lib/mystring/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mystring/Makefile.am')
-rw-r--r--lib/mystring/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/mystring/Makefile.am b/lib/mystring/Makefile.am
new file mode 100644
index 0000000..c9abf42
--- /dev/null
+++ b/lib/mystring/Makefile.am
@@ -0,0 +1,26 @@
+noinst_LIBRARIES = libmystring.a
+EXTRA_DIST = ChangeLog iter.h join.h mystring.h rep.h trace.h
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib
+
+libmystring_a_SOURCES = \
+ append.cc \
+ assign.cc \
+ count.cc \
+ fdobuf.cc \
+ find_first_ch.cc \
+ find_first_of.cc \
+ find_last_ch.cc \
+ find_last_of.cc \
+ iter.cc \
+ join.cc \
+ lower.cc \
+ lstrip.cc \
+ mystring.cc \
+ rep.cc \
+ starts_with.cc \
+ rstrip.cc \
+ sub.cc \
+ subst.cc \
+ strip.cc \
+ upper.cc