summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys/unix/nonalsa/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys/unix/nonalsa/Makefile b/sys/unix/nonalsa/Makefile
index 6399b42..c18c7f5 100644
--- a/sys/unix/nonalsa/Makefile
+++ b/sys/unix/nonalsa/Makefile
@@ -50,13 +50,13 @@ jnyqide/jNyqIDE.jar: $(JAVASRC)
# Standard list of includes (common to all unix versions)
# Keeping portaudio and libsndfile sources local to nyquist
INCL = -Inyqsrc -Itran -Ixlisp -Isys/unix -Icmt -Iffts/src \
- -Inyqstk/include -Inyqstk -Iportaudio/include -Iportaudio/src/common \
- -Iportaudio/src/os/unix
+ -Inyqstk/include -Inyqstk
+
# system dependent stuff for nonalsa:
-AUDIOLIBS = -lsndfile -llo
+AUDIOLIBS = -lsndfile -llo -lportaudio
CC = gcc
@@ -74,7 +74,7 @@ CFLAGS = -DOSC -DCMTSTUFF $(OPT) $(INCL) \
LN = g++
AR = ar
# to enable command line editing, insert -lreadline -lcurses
-LFLAGS = $(LIBPA_PATH)/libportaudio.a $(AUDIOLIBS) -lm -lpthread -lrt
+LFLAGS = $(AUDIOLIBS) -lm -lpthread -lrt
TAGS:
find . ( -name
@@ -275,7 +275,7 @@ portaudio/Makefile:
$(LIBPA_PATH)/libportaudio.a: portaudio/Makefile
cd portaudio; make
-$(NY): $(OBJECTS) $(LIBPA_PATH)/libportaudio.a
+$(NY): $(OBJECTS)
$(LN) $(OBJECTS) $(LFLAGS) -o $(NY)
# copy appropriate system.lsp and make it read-only;