summaryrefslogtreecommitdiff
path: root/sys/unix/nonalsa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sys/unix/nonalsa/Makefile')
-rw-r--r--sys/unix/nonalsa/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys/unix/nonalsa/Makefile b/sys/unix/nonalsa/Makefile
index 9f01331..18de908 100644
--- a/sys/unix/nonalsa/Makefile
+++ b/sys/unix/nonalsa/Makefile
@@ -11,7 +11,7 @@
# This is the resulting executable (normally "ny"):
NY = ny
-OPT = -O2 -m32
+OPT = -O2
# OPT = -g -m32
EVERYTHING = $(NY) runtime/system.lsp jnyqide/jNyqIDE.jar \
@@ -72,7 +72,7 @@ CFLAGS = -DOSC -DCMTSTUFF $(OPT) $(INCL) \
-DHAVE_LIBPTHREAD=1 -D_FILE_OFFSET_BITS=64 \
-DSTK_NYQUIST -DUSE_VSPRINTF \
-DHAVE_CONFIG_H
-LN = g++ -m32
+LN = g++
AR = ar
# to enable command line editing, insert -lreadline -lcurses
LFLAGS = $(LIBPA_PATH)/libportaudio.a $(LIBLO_PATH)/liblo.a $(AUDIOLIBS) -lm -lpthread -lrt
@@ -283,7 +283,7 @@ bin:
mkdir bin
liblo/Makefile:
- cd liblo; ./configure CFLAGS=-m32 LDFLAGS=-m32 CXXFLAGS=-m32 --enable-static --disable-shared
+ cd liblo; ./configure $(DEB_CONFFLAGS) --enable-static --disable-shared
# sometimes, residual files cause problems
cd liblo; make clean
@@ -302,7 +302,7 @@ bin/test-client: bin $(LIBLO_PATH)/liblo.a
portaudio/Makefile:
# note: without-jack avoids 32/64-bit link error on Debian
- cd portaudio; ./configure CFLAGS=-m32 LDFLAGS=-m32 CXXFLAGS=-m32 --enable-static --disable-shared --without-jack
+ cd portaudio; ./configure $(DEB_CONFFLAGS) --enable-static --disable-shared --without-jack
# sometimes, residual files cause problems
cd portaudio; make clean