summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichael Schroeder <mls@suse.de>2014-12-08 13:48:13 +0100
committerMichael Schroeder <mls@suse.de>2014-12-08 13:48:13 +0100
commit0984e7ea93f330a09b43a016f3d45c5c965994b6 (patch)
treed15baf70f4b8e2e514ba7346f30f2d0d4f8e7b6f /Makefile
parentc52276e2b1a096c1fb4df4f776d323fe31b93668 (diff)
rework installed package handling
- changed the build id, it now contains the epoch and the arch - add Build::queryinstalled() function, support Rpm/Arch/Deb - add listinstalled utilities that returns all installed packages - support package erasing for arch linux - add new pkg_prepare step for pre-installation work
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e0f5a25..346a908 100644
--- a/Makefile
+++ b/Makefile
@@ -47,6 +47,7 @@ install:
debtransformzip \
mkbaselibs \
mkdrpms \
+ listinstalled \
createzyppdeps \
createarchdeps \
createdebdeps \